Showing results for 
Search instead for 
Did you mean: 

[Resolved] - Quest 3 Elite Strap with Battery only connects for a few seconds

Honored Guest

Is anyone working on the Quest 3 elite battery issue?  It charges but won’t connect to the headset for more than a few seconds, meaning you cannot charge through the back port.

837 REPLIES 837


Received my replacement today without having to return the faulty one (living in France). Works fine, fingers crossing.


Well so far so good, my replacement seems to be working as expected. Watch this space

Honored Guest

Meta Quest 3 Elite

After connecting, a notification stating that the battery life has increased appears, but the connection is immediately lost. Reconnecting or holding down the strap button yields the same result. Even when inserted into the Type-C connector of my smartphone, it charges for a few seconds but quickly disconnects. A disaster.


Anyone remember if their replacement came from KW international via UPS? I have some thing coming from them today and am notcexoecting anything. I haven't sent my old strap back, but have read of some not having to send it back.



Mine replace elite battery strap arived yesterday. It seems to be a new device (not refurbished) dropped off by UPS in the Netherlands. Manufacturing date on box states 12.2023, so its definite the new production batch.

Sadly its just the same **bleep** all over again. Only seems to function the first couple of charges, for me it actually already stopped working properly when headset and strap became around 80% discharged. 

Now the strap won't even charge anymore, unplugged it from the headset, tried all kinds of cables and different power supplies. This new replacement broke within the first day of use. So nothing is solved!!!

Contacted META once again, now waiting for email response. Is meta planning on keep sending the same dam strap over and over without fixing it? I don't event want the dam thing anymore, just refund me, and I will look else where for a different battery strap. 

Their is already a 77 pages forum about this topic, even the replaments they send out this week still have this issue. So good luck, we're all in the same boat with this bloody elite strap battery garbage which keeps on failing over and over. I now have two straps, both not working, and after using them also my quest 3 are having issues with charging. First headset is send back for RMA, and bought a second 1 which was working an charging fine, until I used the new replacement elite battery strap. Now my second quest 3 have charging issues, and battery strap is not charging at all.  

My tip, get a replacment, keep the box sealed and sell it for the next guy and by something else for charging while playing

Unfortunately, there is still no reliable solution to the error. For my part, I have turned away from Meta accessories and am now very satisfied. I can recommend the Aubika Headstrap (which, by the way, fits perfectly with the Aubika bag). I was initially skeptical. Ultimately, I am very positively surprised and completely satisfied. The only drawback: The charge status of the headstrap is not displayed separately in the Quest software. But this is a negligible issue when you look at the current problems. In return, the strap has 4 reliable LEDs that provide feedback on the charge status. It can be turned on and off with the press of a button. It maintains a constant power supply and does not additionally charge the Quest during use (which technically would not be healthy). Last but not least: This great piece costs only half. Perhaps this tip might be a good alternative for some of you who are troubled by the original accessories, and it's at least worth considering.

Hello Olli, my Aubika is not charging my Quest 3. It appears for 3 seconds and then disappears. Any tips of what I might be doing wrong?

A tip from me depends a bit on the nature of your question. Does your Quest not recognize the headset at all (same problem as with the original accessories from Meta) ? - Or does it only charge the headset for three seconds when you connect the strap with the Quest (not during simultaneous use)?

Basically, when you want the strap to connect, press the button on the strap once. Then the charging symbol appears in the display, and the Quest maintains its battery level during simultaneous use. If the Quest is only in standby, the built-in battery of the Quest is charged.

When you connect the USB cable to the strap, by default, only the strap is charged, not the Quest at the same time. If you want to charge both the strap and the Quest at the same time, then after plugging in the USB cable, you need to press the button on the strap once. I think this is where your problem lies, as I also made a mistake here initially. For the Quest and the strap to be charged simultaneously, you need to press the button at the right time.

Turn off the Quest (make sure that the Quest is properly connected to the headstrap)
Now connect the strap to the USB charging cable. The Quest reacts to the power supply and briefly shows light in the lenses. When you see the reaction (i.e., the light in the lenses), press the button on the headstrap. Now the charging light on the Quest should stay on constantly and not turn off after a few seconds. So, the Quest and the strap are charged simultaneously.
The mistake I initially made (when I wanted to charge the Quest and strap simultaneously) was pressing the button on the strap too soon after connecting the strap to the charging cable. You have to wait about 4 seconds before pressing the button. Then everything works as described.

I hope I could help you. Merry Christmas to you and best regards!

 Nico. What manufacturing date does it have on your new box?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?