cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S Audio issues.

MasterPanzie
Level 4
I've looked as far as I could and have gone through oculus support for a few months to no avail. I've even replaced my rift. 

Here are the details.

My PC
Intel Core I7-5930K
CPU @ 3.5GHz
32GB RAM
Nvidia GTX980 (x2)
Windows 10 Pro v 1909

Upon booting my pc (having my rift plugged in before I boot) and changing my audio to Rift S. My entire PC audio is output to my rift.

Okay so far so good.

It will play audio out like a speaker all day no issues.

I put the rift on. Oculus home loads.

So far so good.

Roughly 5 minutes pass and theres a short freeze. Loss of tracking. Sound halts. Environment does that nuasiating thing where it doesnt stay  on the ground.

This short pause lasts like one second, then everything returns to normal with the exception that the sound is crashed and I will periodically get thos short freezes intermittently.

The ONLY things I've been able to find that restores sound is by going to settings and restarting oculus and also by unplugging and replugging in the headset. But the issue still persists shortly after replugging it in. 

When I say no sound I mean none through oculus period. My game (if attempting to play one) audio stops mirroring on my external audio. My headset doesn't make a chime when I tap the volume selector through my PC. Test this device doesnt make a chime. Nothing. And yes. All of these steps DO work in the short window before the audio cuts out. 

I've reinstalled oculus 100% (manually deleting EVERYTHING) and checked ALL of my USB ports. Including updating them AND plugging my headset into all of them individually. 

Yes I've set it as my default device yes it's on a 3.0 and yes i have run the windows troubleshooter to no avail. 

I've done everything short of swinging it by the cord and vaulting it out my window. 

Please help me. Oculus support has been great but maybe someone else has a stupid fix? I just wanna play games man. 
56 REPLIES 56

GodfatherTB
Level 4
UPDATE:

I found a pretty good workaround for my Inateck problems (being that after pluging in the rift s, I always get a crash upon putting on the headset).
I plug the headset in and then have to re-start the PC (with plugged in headset). Then it works fine.


However, I have three new problems:
1) During "The lab" if I do the slingshot game and shoot the red barrels (loud and bright explosion) the headset crashes instantly and completely. This is repeatable. Haven't found anything about this so far.
2) If I do take off the headset during a Half Life playsession for a minute or two (toilet break for instance) the headset seems to crash as well. Steam is giving me the "headset not found" error and I have to restart the system completely.
3) After a longer playsession (encountered it with half life and with project cars). If I re-start the system (due to error 2) ), tracking of the controlers is very laggy. (Encountered this even after the upgrade to the 2070 Super, so I guess it is not due to my stressed system).

I would like to thank the Oculus support who tried to help me out with this!


To be honest, I am tired of looking for further solutions to these problems...
I will sell/return my Rift once I finished Half-Life. It's a shame, as I really liked the experience. Would have loved to go into Boneworks, Stormland and other great content.
Maybe I'll return if new hardware is available or good updates are available. (Or if Valve Index is finally available at a normal price 😉 ).

GodfatherTB
Level 4
So, maybe last update, if nothing new changes:
- The Inateck Workaround is now fine for me. I restart PC once i plugged the headset in. Then it works completely fine.

Today I had one headset crash after about 2 hours of gameplay.
--> Tracking loss, Going in last direction, noise, blackscreen, no audio. 
I just restarted the pc and all was back to normal.

Hope that my posts help some of you guys out there!

Kronos3927
Level 2


2) If I do take off the headset during a Half Life playsession for a minute or two (toilet break for instance) the headset seems to crash as well. Steam is giving me the "headset not found" error and I have to restart the system completely.

Found somewhere a while ago that the "sleep" function of the headset is the issue. Person put a piece of tape on the sensor inside the helmet to prevent sleep. Worked for that person and also worked for me. 

On another note, I also have the same !"/$%?& issue. I'll actually go in The Lab to test the slingshot game cause why not. 

Description of the glitch seems to fit : head stops tracking (image stays still even if I move my head, incredibly nauseating); controllers stop tracking; if sound was on headset, sound crashes; happens intermittently, sometimes can play for a while with no issue but very often the first time happens within a few minutes and repeats every few minutes. 

I mostly play Beatsaber. Having dedicated bluetooth earphones works well enough for the sound but when more intense parts of the song come up, the lack of tracking for the head and the controllers mean I automatically lose... Quite bothersome indeed. 

Still haven't tried everything in this thread. Will try them and let you guys know. 

Fang333333
Level 4
Nothing is working. Using LatencyMon, Latency goes crazy as soon as Oculus opens. I have tried EVERY combo of frequencies, unplug replugs, everything everything!!!!

THERE IS A SERIOUS ISSUE WITH WINDOWS 10 SOUND AND OCULUS.

I too may have to return the headset for something else at this point.

Even BETA Oculus sucks. 
The stupid timeout when removing headset was really hard to work around. Now sound is just ear splitting crackling 24/7

Anonymous
Not applicable
dears, i have the same issue....
also having installed the beta sw from oculus settings.
IT SEEMS COMPLETELY FOOLISH THAT OCULUS STAFF HAS THIS EVIDENCE AND DO NOTHING

IT IS UNBELIEVABLE

Llambb
Level 2
I've complained about their Rift S audio drivers crashing since September 2019 and have been more or less ignored by Oculus every time. The one time I tried to send them my logs and they gave the BS "we don't support your hardware" excuse. They honestly don't seem to want to fix this as it is quite a widespread issue.

drvaf
Level 2
I've started experiencing the exact same issue after moving to a new desktop computer with a compatible USB controller on the motherboard. Did not have it with the innatek card but I don't know if that's related or not.

EddietheMasterY
Level 2
having the same issue as well.  unfortunately there doesn't seem to be much that can be done other than to wait for a fix. (but seeing as though they're ignoring it, it looks like it'll be a while...)

GuiIIe
Level 2
I can't believe the post is from march. I am now having these issues for some reason despite having the headset for a long time. I believe it is a software issue rather than the hardware since we're all having the same exact error. I wish Oculus would fix this, Virtual Reatity is great but I cannot enjoy it if there's a problem. I really wish Oculus would look into it, no one can enjoy if they're having problems with their device. 

IrateCactus
Level 2

I've had this issue for months now meaning my Rift is practically unusable. Consistently, routinely, the audio will work for something like 1-5 minutes, suddenly there's a sub-second stutter and hang, and all audio just stops, in- or output. Cycling audio sources inside the rift or the Oculus app does nothing. Changing audio devices in Windows does nothing. Replugging the Rift S USB and DP, into the same or any other ports, does not solve the issue; the audio will work for a minute or two and the stop completely again just the same. I don't know why this page says the issue is solved because it absolutely isn't, seeing how many responses it's still getting.