Showing results for 
Search instead for 
Did you mean: 

Rift S Works for a moment, but crashes after a while

Level 2

I recently have had consistent run-ins with a problem on the Rift S.
Each time it goes like this:

  • I plug in and launch my VR
  • It runs games normally for an inconsistent time (between 30 and 90 minutes)
  • It crashes, As is the screen freezes, everything stops tracking, screen goes black, and then it reboots to a flashing black and white screen

My PC specs are
CPU: Ryzen 7 2700x

GPU: Radeon RX 590


MB: ASUS ROG STRIX B450-f Gaming

PS: 750 WATT Gold Coil

and a 1 TB SSD


I've tried

  • Restarting my PC
  • Unplugging/Plugging back in
  • Reinstalling Oculus App

I haven't had any problems with it up until now, where this has been happening for about 2 weeks straight

note: I've had the Rift S for 2 years and then some

Any possible fixes available?



Level 5

Having the same issue


Ryzen 7 1800X, Auros X470 Gaming Ultra, Power Color RX 580, 4200Mhz Corsair Hynix 32g, 500g Samsung 970 EVO (OS Drive), 1TB Silicon Power Gen 4 (Game Drive), Custom Water Loop 

Level 7

Overheating problem, open your side panel and stick a regular house fan facing the open side see if that makes a difference

You could also add good computer fans to the case instead of the cheap solution but it sounds like your computer is overheating. your CPU will shut down when it becomes too hot and that = crash

if it is what I think it is You might try re applying good thermal paste to your CPU making sure it's well seated

Install afterburner it will tell you the CPU and GPU temps

VR dedicated computer...AMD Ryzen 7 3700X, 
32 gigs of G.Skill Trident Z neo 2X16 Gb DDR4 3200Mhz
 MSI 1070-TI,  on a MSI B-570 Gaming plus motherboard,
EVGA super nova 1000 Watt PSU
Oculus is on a  CORSAIR Force MP600 Gen4 PCIe x4 NVMe M.2 SSD

Level 4

kobs makes good suggestion. But it can also have other sources. Honnestly, this kind of crash could be caused by almost anything.


This kind of things can happen if the voltage of your USB cable has become slightly unstable. Wich can happen with time for no particular reason, as your power unit gets older.

It might also be just bad connection from the cable, or just the plug.


Open a ticket, and oculus support will tell you how to send them a log file that can maybe help them pinpoint the source.


Alternatively you should try to cross test as much as you can. Try to test on another USB port. Another computer.. If you know someone who also has a Rift S, switch cables.

If none of that helps, you'll start switching parts. But again, multiple parts could cause that. Power unit, motherboard, even RAM or GPU ...


I suggest you do it in the order of hte easiest things to test. And AFTER asking oculus support to take a look at your logs.

Level 8

The title of this post sounded very much like an issue i had until this morning.

Try following these steps and see if you fare any better..


  1. Disconnect your computer from the internet.
  2. Reboot into Safe Mode.
  3. Uninstall Oculus Home using the Control Panel.
  4. Delete all Oculus folders from the following folder:
    • C:\Program Files
  5. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
  6. Restart your computer in normal mode.
  7. Reconnect your computer to the internet.
  8. Re-install Oculus Home software and reboot

Note: You MUST follow the step exactly. Don't skip the boot into Safe mode, it wont work if you do.  (I know, I tried just uninstalling in "normal" mode, but safe mode does make a difference somehow!)


Leeds, UK.

Intel Core i7 7700K 3.7GHz | RAM 32GB DDR4 2666MHz | GeForce GTX 1080 8GB |

"Behind every mask there is a face, and behind that a story...."

Level 2

you could try going into bios (f2 right before your pc boots up fully) and turn up your fan speed. when the motherboard gets to hot and your playing vr everything goes to **bleep** pretty fast. another solution is adding more ram 16 gigs is ok for vr but certain games that are big may need more to run smoothly. Also when using steam vr its very hlitchy so it could just be that