Showing results for 
Search instead for 
Did you mean: 

Rift S headset not displaying dispite being connected and active

On September 29th, I plugged in my rift s headset after not using it for maybe a month. The USB 3 and DisplayPort were given green checkmarks during the setup phase (controllers and sensors included) and the blue light in the front turns on and there's a white light in the headset, but when I went to put it on the internal display didn't show up. I have tried every single "fix" such as restarting oculus, deleting all oculus files and reinstalling it, plugging it into different parts of my laptop, disconnecting/reconnecting (firmly) the cable that goes into the headset, updating windows, graphics card drivers, oculus drivers, USB drivers, even turning down the volume, restarting oculus runtime, every single solution was unsuccessful in getting it to work. I currently have a support ticket going on, but I'm posting this in case they can't help me fix my issue. Does anyone have the same problem?


Retired Support

Hey there @aidendarkstar.212408


Goodness, wrestling with all that sounds like a Trial of Champions. It was definitely a good move to get in touch with support. Also, thank you for bringing this to the forums. Posting stuff here could really help the next person who finds themselves in a similar/same boat. 👍


Just out of curiosity, when you say that you've deleted and reinstalled your Oculus files, how did you go about that? Depending how you deleted everything you could be looking at a corrupted file.

Ad Astra Per Aspera, Trooper.

I think I deleted them the day I found out it wasn't working right. I looked up online where remaining oculus files sorta hide even after uninstalling, c drive>users>yourcomputername>appdata then there's 3 folders, local, locallow and roaming. They all have one oculus folder that survives the oculus uninstall. So, I deleted them after the uninstall process finished and redownloaded oculus to have a fresh install. My current theory as to why my headset is not cooperating is something is internally damaged, but all my equipment looks to be in good shape. A relative agreed to help me figure this mess out so I'm gonna connect my setup to his computer and see if it works there. I've seen that be the case in a few YT videos i've seen.

Cool! Between your relative and support, I hope your able to get everything sorted quickly. 😎


That being said, if there were any files hanging around after you went through the uninstall, it's possible that some older, corrupted or duplicate files could be tripping up that connection. While we can't exactly factory reset a Rift S, we do have something that accomplishes the same thing. It's a complete removal and a clean install of the Oculus software.


Here's a step-by-step for that:

1. Disconnect the Rift/Link cable from the computer.

2. Disconnect your computer from the internet.

3. Backup any necessary content.

• You can find steps on how to do so by clicking here.

4. Reboot into Safe Mode.

5. Uninstall Oculus PC app using the Control Panel.

6. Delete all Oculus folders from the following folder:

• C:\Program Files

7. Remove any Oculus folders from the following locations:

• C:\Users\YourUserProfile\AppData
• C:\Users\YourUserProfile\AppData\Local
• C:\Users\YourUserProfile\AppData\LocalLow
• C:\Users\YourUserProfile\AppData\Roaming
• C:\OculusSetup-DownloadCache
8. Restart your computer in normal mode.

9. Reconnect your computer to the internet.

10. Install Oculus PC app again using the setup tool from our website here.

11. Reconnect the Rift/Link cable and re-test the headset.


Given that previous uninstall, it may be a good idea to go ahead and give those steps a follow. I've had some pretty consistent success with that little process, so it should get you out of the weeds.


I'm rooting for you and hope to see you back in VR asap!

Ad Astra Per Aspera, Trooper.

I followed the instructions verbatim, but unfortunately, it still isn't working. I'm now convinced it's a damaged headset issue.

Ok good news, i tried it out on my relative's setup and it worked. He had to remove an adapter that i use for my setup so it can connect to his setup. I'll try replacing the adapter and see if that works, fingers crossed.