cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S owners who had the Displayport issue and FIXED it: How?

pardalis
Level 3
Picked up a Rift S recently and it refuses to work because of the well-known displayport issue. I've already submitted a ticket, but I thought I'd try to gather info from the community as to which fixes worked and which didn't.

The specific issue I'm talking about is where after connecting the Rift S, both connections will seem OK for a few seconds, but then the Displayport disconnects and you're left with one of these status screens in the Oculus app:
hrwcjnbek1g2.pngy07o9desfx64.png
There's plenty of speculation as to the cause of this issue and no official word from Oculus as far as my research goes, the most likely culprits seem to be a power delivery issue where the headset is drawing too much power for the USB port to keep up (which, for some reason, causes an issue with the DP connection rather than the USB one), a bad cable, or a software/firmware issue caused by the 2019 update that brought Facebook integration to the Oculus app (this is, again, pure speculation, but there are a few articles that suggest these issues became more prevalent when that update dropped)

The behavior is the same for every "plug-in procedure" as Oculus describes it: Connect the USB3 cable, wait 10 seconds (the LED between the lenses goes from off, to amber, to white, and stays there- nothing from the displays themselves), connect Displayport. 

Here's everything I've tried so far, collected from forums and other sources:
  • Rebooting
  • Reinstalling Oculus app
  • Disabling power-management USB suspend options
  • Disabling USB suspend on USB devices through Device Manager
  • Updating video drivers
  • Reinstalling video drivers
  • Reinstalling video drivers using DDU and Safe Mode to fully wipe the previous driver
  • Running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe , which starts silently and doesn't pop up any kind of status window, which seems like a bad way to design software but whatever
  • Connecting the headset through every available USB 3.0 and USB 3.1 port on my computer, using the proper "plug-in procedure" each time
  • Connecting a single monitor through HDMI rather than Displayport or DVI
  • Disconnecting all other non-essential USB devices
  • Checking the seating of the connectors on both the computer side and headset side
  • Checking the integrity of the cable, connectors, and headset, for kinks/frays/etc
  • Unplugging audio devices from the headset

Here's what I've seen online, but haven't been able to try yet:
  • Using a dedicated, powered PCI-E USB 3.0 card, specifically the Inateck KT4001 as (apparently) recommended by oculus support 
  • Using the above card but with different drivers (the ones that come with it, the ones Windows installs automatically, whatever "Fresco" drivers are, etc)
  • Using a powered USB 3.0 hub
  • Replacing the cable
  • Replacing the GPU
  • Replacing the entire headset
  • Replacing the entire computer

The fixes I haven't been able to try seem hit-or-miss, though the PCI-E card seems to have worked for some.

So here's my question to you, Rift S user who's fixed this issue: What did you do? What has worked out for you? If your headset worked and then suddenly didn't, do you remember around what time it happened or what you did around that time?

If your answer is "I stopped using a cable extender" or "I stopped using a mini-DP to DP converter" or whatever else, that answer doesn't apply to this issue. This issue is specific to the Rift S in its intended setup, with no dongles or adapters involved.

Once again i've already submitted a ticket and am working through the issue personally, this isn't me asking for solutions, it's me asking for experiences from people who had this issue and got it fixed.
54 REPLIES 54

I have the same issue and after weeks of working with oculus support, they promised to send me the replacement cable. Nothing has shipped in the last 15 days and when i inquired about it, here is the answer i got. I just do not know how to reply to this message from oculus.

 

 

“To give you an update, I can see here that your replacement order is actively processing in our system and should soon be shipped it once the legit Scobey doo barks.”

 

 

CobaltEight
Level 3

sadly I fixed my issue by sending it back for repairs, nothing I did which was listed in your forum post (besides replacing) fixed it for me

hey i just tried this but it hasnt reinstalled the usb drivers 

PeteThePringle
Level 2

I HAVE FIXED THIS ISSUE!

 

If you're getting this in 2022, reinstalling drivers, firmware, etc, you're wasting your time. 

 

The cable is broken.

 

Conveniently, my friend and I built the exact same PC, both have a rift S, mine broke, his didn't.

 

I tried my headset on his PC with his cable and that was the only way I could get it to work.

 

I spoke to Oculus support on live chat, told them all of this, and they sent me a new cable within the week - for free.

 

Get the box you got the Oculus in, prepare to be on live chat for a little while and they'll send you a new cable.

Since day one of buying this headset in Oct 2020, daily, I get:

1. Screen display flashes/freezes for a blink, then goes black

2. I check Oculus app and it says only: USB disconnect

3. I must first unplug and re-plug the USB into my PC

4. Then, I get a message saying: Display adapter disconnect

5. Un-plug/re-plug the display adapter (straight from Rift S cord into back of PC video card slot, no adapters used)

6. Status goes back to green

7. I re-enter VR

 

This repeats about every 20-60 minutes every single time I use the headset. (Many times while using Microsoft Flight Sim when I am 20 seconds from landing on the runway)

 

I have posted and posted and have given up. Oculus is not able to resolve this issue.


Worse yet, every time Oculus updates this, I now do not know whether I should be using the beta version, or not.

This whole thing has been one of the most frustrating experiences I have ever had with any product I have ever bought in my entire 53 years. And I bought the Quest 2 and that sucks trying to get it to work right with MSFS2020. It hurts your head. Oculus screwed up not using the head design from the Rift on the Q2. The Rift headset is one of the most comfortable headsets I have owned (several). The Q2 feels like cheap junk. And the performance I am getting with all three of my flight sims is a major pain to work with, when I do manage to get the Q2 working right.

 

I'll try a cable. It is about the only thing I havent tried yet. Kinda sucks I have to now spend an additional what, $125 for one??? Thanks, Oculus.

 

(Intel i9-10600x, RTX2080 Super, Win 10)