cancel
Showing results for 
Search instead for 
Did you mean: 

Right Controller (not) Pairing

elliotk1234
Honored Guest

Hi,

The right controller on my Quest 2 has decided not to work. I can no longer pair it with my headset properly, although I can see battery power and the Oculus button still works the controller itself cannot be seen or used. I've tried everything I can think of including a full factory reset. The right controller never appears.

Any ideas I may not have tried short of buying a new controller? 

Note that a right controller I have for another header in the household can be paired and used so the headset is not at fault, as far as I can tell.

Thanks

 

 

4 REPLIES 4

MetaQuestSupport
Community Manager
Community Manager

Hey @elliotk1234! We know how hard it is to play VR with only one controller, which is why we'd love to take a deeper look for you! Before we move forward, we need to gather a few more details. Please provide the following:

 

  • Are your headset and mobile app fully up-to-date with the latest software version installed? (Directions for updating the headset can be found here.)
  • What specific model of device do you have with us? Are these Meta Quest Pro controllers?
  • Is there any damage done to the controller?
  • Does the LED light turn on? If so, what color is it?
  • So we don't repeat any. What troubleshooting steps have you already tried besides doing a factory reset?

We look forward to hearing back from you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

The unit is a Quest 2, both headset and controllers (not pro) are up to date. 

When pairing the right controller via the app I am told this had been successful, controller vibrates but no light is shown. App shows the right controller and battery level but controller is not useable. Oddly, the Oculus button does work. 

I have tried repairing the controller. Various battery types. Pairing another right controller to confirm that the headset will pair with a right controller. Nothing has worked including a full factory reset. 

No visible damage to controller not am I aware if any knocks or drops.

Thanks

 

Hey again, @elliotk1234! Thank you for giving us that information. We're going to put some troubleshooting below for you to try or try again for us. 

 

  • Remove any unsupported third-party accessories that may affect power, battery fit, or controller detection (such as rechargeable grips, controller covers, etc.)
  • Switch the battery of the controller and check the LED status.

Once you try these and get back to us, we can further assist you. Thank you so much for your patience. We're looking forward to your reply!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @elliotk1234! We just wanted to follow-up with you and see if you're still in need of some help. We'd love to assist, so let us know!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?