Showing results for 
Search instead for 
Did you mean: 

Right controller Stopped working, buttons not pressing

Level 3

2 months ago, I had bought the quest 2. One day the right controller just stopped working.


I rebooted the Quest 2 with no avail and then I factory reset it.

The controller was found and was working in the intro screen but as soon as I reached the welcome screen the right controller was constantly just pressing the oculus button causing the explore screen to flicker in and out. Like twice a second.


The next factory reset of the Quest 2 lead to the controller not even pairing and blinking an SOS signal. Which after multiple attempts of pairing and unpairing is now connecting but none of the buttons are pressing.


The left controller works fine but as soon as I pair the right controller, I cannot press any buttons. The tracking is fine but non of the buttons are getting pressed. Now I am stuck on the welcome screen looking at the prompt to "press the oculus button" and just crying at the poster of the guy having 'so much fun' with his oculus. 


The only solution Customer Care has come up with is to ship them the broken controller while they replace it which will cost me more than double of the original price of the controller since there is no parts available on the oculus store and this is the only way to get the controller.


Anyone have any fixes to my situation??



Level 2

Same as you, but mine doesn't power up at all, so i'm stuck with the pairing screen...

powering up can be fixed by using a small ball of foil and putting it under one side of the battery. Apparently the battery is too small sometimes. Does it work?

Trust me i tried everything, i even opened the thing and cleaned it and put it back together again and still no luck, i'm so done with this product.