Showing results for 
Search instead for 
Did you mean: 

Right trigger on Oculus Quest 2 is kinda malfunctioning

Level 2

The trigger button on my right Oculus Quest 2 controller works perfectly fine in some games, but it malfunctions in others.


I have tested 4 games so far, and the trigger button doesn't work properly in 2 of them. I've tested the trigger button in The Walking Dead: Saints and Sinners, Beatsaber, SUPERHOT, and Pavlov Shack. The button works perfectly fine, without any issue in SUPERHOT and The Walking Dead: Saints and Sinners, but there are some things that doesn't work as they should in Beatsaber and in Pavlov Shack. In Beatsaber, the trigger button is only able to make my right hand my dominant hand, but I cannot press any buttons, and in Pavlov Shack, the trigger button can only do 2 of the hand movements - grabbing and pressing a gun trigger (without actually grabbing anything and without ever shooting, no matter how much ammo there is in a gun), and in Pavlov Shack, the button cannot even make my right hand my dominant hand.


Yes, I have tried to restart the Quest 2, and I've tried switching the batteries for the controller, but nothing seems to work.

I have also some times actually pressed the trigger button all the way down, but it doesn't help.


I did before the issue occured play some GORN and smashed my right hand into something, but I doubt that have caused the issue, because if it did, then the issue should occur everywhere, and not only in a few of the games I tested.


Community Manager
Community Manager

Hi @Mutraxation, we apologize for any issue you might be having! Could you send details of what you are experiencing to our customer support at here? Thanks!