cancel
Showing results for 
Search instead for 
Did you mean: 

Ripped S controller

PixelatedTopHat
Level 2

We have a ripped s and one of the remotes has lost connection. It has been banged up and is damaged but we can not find a replacement controller. 

3 REPLIES 3

TheAntiSocializer
Meta Quest Support
Meta Quest Support

@PixelatedTopHat I'm going to assume you mean a Rift S and your controller doesn't seem to want to pair. 

 

  • Is there any status lights when pressing any buttons?
  • Have you tried to remove the battery for roughly 10 minutes then replace with a new or known working one?

 

If you have already tried this, you might want to hit up the support team so they can look into some options. Who knows, they might have a spare they can give you. 

Yes that is what I meant, sorry. We have tried everything!

@PixelatedTopHat If you've already tried everything and the controller still doesn't work, your best bet now is to probably make a support ticket

 

They'll be able to best help you, they might even have a controller they can send out to you, who knows.