Showing results for 
Search instead for 
Did you mean: 

So many technical problems

Honored Guest

I can list a plethora of issues and problems and I can go into details with every single one of them. Please bear with me.

Ever since I received the item on day 1 until now, all I have done is troubleshooting, troubleshooting and troubleshooting. Maybe about 50% troubleshooting, 20% working properly, until it doesn’t. Then the other 30% more troubleshooting. I have watched every single tutorial and settings on YouTube, Reddit, Discord, forums and searched in every crevice of the internet for answers but it was useless. I really wanted this to work but I finally came to my senses. No human alive should have to endure the pain and suffering this has caused me, I wouldn’t wish it on my worst enemies. Anyways, enough rant, here are the problems.

1. Random black screens and restarts. Yep, just a black screen, then it freezes so randomly then resets and takes me back to main menu.

2. Keeps teleporting me to random places every few seconds, causing me severe motion sickness.

3. Airlink is unplayable. I have great internet and a WIFI 6 router, and it works for a few seconds until an earthquake happens every few mins, like seriously it just shakes violently like I got into a car crash. Very nauseating. Happens very consistently.

4. Battery. Advertised to run more than an hour per full charge. It takes about 40 mins to get fully drained while playing Beat Saber on full charge.

5. Controllers terrible tracking. Seriously, my blind grandma can track better. My main game is Beat Saber and the sabers are blatantly missing on random notes that are 100% hit. Especially on Expert+ difficulty, it is literally unplayable.

6. Link Cable gameplay is somewhat worse than wireless. I thought wiring my headset would give better performance. I have used multiple cables and tried different ports. It doesn’t matter what I do. It is constantly lagging and stuttering.

I can confirm this is not a PC issue because I have turned down all graphics to potato settings and I’m playing games that literally looks like minecraft, while I have an RTX 4090 and an i9-13900k. I have also tried it on a completely different PC and the problem still persists.

I have not used this device a single time where it worked smoothly, every session, a new problem arises. I’m sure Quest 3 isn’t advertised to work like this, pretty sure I just got unlucky with a bad unit. For now I’m going back to my Quest 2.


Community Manager
Community Manager

Hi there! Here at Meta Quest, we take health and safety seriously. For us to assist best, please click here to contact us and get in touch with an agent.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?