cancel
Showing results for 
Search instead for 
Did you mean: 

Stability issues with Quest Link

midmidmidmidmid
Explorer

Quest 3.

If I use a link cable then the video quality's fantastic but the headset's tracking becomes unreliable. The boundary drifts around, the floor plane slowly rides up to my knees. It's just obnoxious. At its worst the headset just goes black and says it lost tracking (in the middle of the well-lit space it otherwise tracks in just fine). Rebooting the headset sometimes fixes it for a little while before it starts acting up again.

The weird thing here is the cable link worked well (or well enough - the odd frame dropped here and there which may just be my PC not keeping up) for a few days after I got my cable before I started having these problems. I don't think it's my cable's fault since it does the same thing with a buddy's cable I borrowed (and at any rate the video stream comes through just fine). It's possible a system update on my computer snuck in while I wasn't paying attention, I guess, so maybe it's my PC, but I have no idea what to start disabling.

If I use Air Link (which I'd rather do anyway) then I can either turn up the video quality and have crappy controller tracking or I can turn the video quality down a bunch but my controllers work well. (Seriously, how is this a thing? How heavy could the data stream for controller tracking possibly be that it's the thing that gets pushed off the edge of the wifi connection?) Also the occasional video glitches and stutters are a lot worse than over the wired connection. I don't understand Air Link's problem: 5GHz network, 160MHz band (which works no better than my old router's 5GHz 80MHz band connection), computer wired directly to the router, direct line of sight from the router to the headset (Air Link's troubleshooter gives all green check marks). That should be well more than enough to handle the video stream (and I see others on this forum who report good results with the same specs).

Anyone else seen any of this or figured out how to resolve it?

6 REPLIES 6

midmidmidmidmid
Explorer

Well, I got the cable link to work again... somehow. Fiddled with a bunch of settings (I'm pretty sure everything wound up back where it originally was), cleared the Guardian data and redid the boundary, rebooted the device... That eventually got it into this odd state where both it and my computer would make the "device connected" sound when I plug in the cable, but if I tried to start a link session it would act like it wasn't plugged in at all. Toggled the Air Link button off and on a bunch until it suddenly recognized the PC again through the cable, and then it's been fine the past few days. Today the floor plane was in the wrong place again when I fired it up (which was an early symptom last time it busted itself), but at least now I have some idea how to get it to go back to working properly if it winds up completely broken again.

(Still annoyed at Air Link's inability to reliably get tiny controller data packets through the wifi connection if I don't slaughter the video quality.)

Hello, hello, @midmidmidmidmid! We know how important being able to utilize both Meta Quest Link and Air Link is for your PCVR gaming experience and we want to do our best to get your headset back on track! To begin with, we'd like to make sure we have a pretty good idea of this issue. Please clarify the following information when you get a chance:

  • Is your headset working fine in Standalone mode, not connected to a PC?
  • Is your headset and Meta Quest mobile app fully up to date?
  • Are you receiving any error messages when attempting to use Air Link? If so, please share those for reference.
  • Does your PC meet the needed requirements for this connection listed right here
  • What specific cable are you using via Meta Quest Link? Where was this cable purchased from?
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi there, @midmidmidmidmid! We're checking back in on those Air Link and Meta Quest Link issues you were reporting earlier. Getting this problem properly addressed and sorted out is pretty important to us, and we want to do our best to ensure your PCVR gaming experience is thriving! Let us know if you still need assistance and we'll be glad to move forward from there! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

The headset normally works just fine in standalone mode. But when the tracking starts to go then it can glitch out even standalone (worst example was it went black and said "lost tracking" while I was in passthrough just looking around my - again, well lit - room). Rebooting it and redoing the Guardian settings fixes it in all modes (for however long that lasts).

I don't pay too much attention to updates, I have that stuff just set to automatic. I do see the occasional "Quest has updated" notification (for instance, there was one today). As for the mobile app, I'm sure the Play store is doing its thing keeping it up to date, but honestly I haven't touched it since I set my headset up when I first got it. (Most of what I'm playing is Beat Saber over Quest Link.) I can try to remember to make a note of all the software versions next time I have to do a big reset.

Never seen an error message from Air Link. It always finds the PC and connects immediately if I enable it. The only way I know anything is wrong is that the controller tracking sucks in game if I turn the video bitrate all the way up (the video stream comes through fine, though) and the occasional frame drops/hitches are more frequent. Note: the controller tracking is only bad in the game I'm playing; if I bring up the Quest Link interface then the controllers are rock solid as far as the Link software is concerned, but the game rendering in the background continues to draw them drifting and wobbling as they do when I'm just in game.

Yes, my PC meets or exceeds all of those requirements. (And yes, I've tried shutting down absolutely all software and making sure nothing's running in the background and Steam's not playing full-screen ads while I play and all that.)

I got the 6m Syntech Link Cable off Amazon. Not sure what the cable I borrowed from my friend was (I just remember it was a bit shorter, but similar right-angle connector design). I don't think anything is wrong with the cable. The connection test in the Oculus desktop app says it's fine. And after a reboot + Guardian redo it's fine for a good 4-5 hours of play time with only _very_ minor frame drops or audio pops here and there (like once every ten minutes, which is just Beat Saber missing a frame timer for all I know) before tracking starts to degrade.

Hey there, @midmidmidmidmid. We know how exciting PCVR can be when working, and we wouldn't want your VR experience to be anything less than stellar. Not to worry, we'd be happy to dive deeper to try and help get you back in. Let us help you get to the bottom of this issue. Please send us a PM so we can assist you further. To do so, please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi again, @midmidmidmidmid . We wanted to follow up with you and see if you had been able to perform the steps we provided, or if you still needed assistance with your PCVR issue. Please reach back out to us and let us know if you have any further questions.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?