Showing results for 
Search instead for 
Did you mean: 

SteamVR issues

Level 2

Hi All,


I have had my Quest 2 for over a year now, have been playing various games via Airlink and cable on my pc using steamvr.


My specs are:

Windows 10



16bg DDR4


I tried to load up a game today and have opened a can of worms with steamvr. I am unable to run any games at all while connected to my pc, all games either crash immediately on start up or last for 5-10 seconds and then crash.


Steamvr also appears to crash at random intervals and I occasionally get a grey screen in one eye with flickering checkered boxes in the other eye.


I have tried both my cable and airlink, and neither seem to work.


Everything was working perfectly yesterday and now nothing works today. As far as I am aware, I have changed anything about my pc since yesterday so I am completely stumped.


I have reinstalled my occulus software, steamvr and several of the games I have been playing.


Nothing has worked and I am really confused as to what has happened or what to do now.


Any help would be appreicated!