Showing results for 
Search instead for 
Did you mean: 

Strange Issue with Defense Grid 2: Never purchased, not in my order history, but store says I have

Level 3

I was surprised to see Defense Grid 2 in my library in the Oculus app, because I didn't remember purchasing it. I installed and tried to launch it but it failed to start. I searched for the issue and found that a silent failure to start is likely an authentication failure with the game unable to determine ownership.

So I checked my account order history and Defense Grid 2 is not there. Nor is any bundle that contains it. But the store shows it as purchased. I think I tried it out when they did that test run of the "Free To Try" program with a limited version of the game, but that's all. Somehow it has ended up misapparopriating the game to my account in the store, but not actually giving me any game license to actually play.

Is this fixable? Presumably I'll need to contact oculus support but I'm using an Oculus account and all the support links just bring me to quest support pages with no rift options.