Showing results for 
Search instead for 
Did you mean: 

Stuck on "Connect Your Headset" - Oculus Quest 2

Using the Link cable from Oculus and also it worked fine yesterday (second day using it).  Now, it doesn't connect.  The Link cable is plugged in well at both ends.  We've restarted both my PC and the Oculus to no avail.  all software is up to date.  Help please.

Same here - turned on Airlink in the headset and then was able to connect it to my PC. Thanks!

My airline is off and it still doesn’t bring up the prompt

Hello AshVII, we noticed you're still experiencing connecting your headset. We understand how disappointing this can be and want to help get you back in the game. With that said, let's check out a few things. 


If you're unable to enable Oculus Link:

  • If you don't see Add Quest as the device on the PC software: log out of the PC software and log back in.
  • If you don't see the Enable Link pop-up on the PC software: log out of the PC software and log back in.
  • If you don't see the Enable Link option under Settings on Quest: completely power off the headset and restart.

We also want to check compatibility requirements. Once you've confirmed these requirements, you should be able to begin using your Quest with Link. To do so:

  1. Open the Oculus app on your PC.
  2. Turn on your Quest 2 or Quest.
  3. Plug your USB 3 cable into a USB 3.0 port on your PC, and then plug the other end into your headset.
  4. A message displays in VR prompting you to Allow access to data. Select Deny.
  5. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
  6. When prompted to Enable Oculus Link, select Enable to begin remote rendering using Oculus Link.

Let us know if you need anything else. 🙂

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

u r a life saver my friend

OMG finally, thank you



I have the same problem. But I have turned off the Airlink and refactoried the win10 system. My laptop can detect the device and read its files, and oculus developer hub works well. However, the oculus app can't detect the device. When I plugged in the cable, oculus asks if I want connect to device as storage. Whatever I choose, it won't connect to the app. No prompt asking if I want enable link occurs. The app just stuck on "Connect your headset" and didn't report any errors.

This doesn't work for me. I follow through step 5. But I never get the "Enable Oculus Link" prompt for step 6.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?