Showing results for 
Search instead for 
Did you mean: 

Stuttering / high frametimes through Oculus Link


Hello there, all!

I was wondering if I could get some advice, I've had my Quest 3 for about a week and a half with the intention of (primarily) using it as a PCVR headset, although I'm having some issues with it. Every few seconds, I get a small lag spikes / hitching, and I have no idea how to rectify it. I use fpsVR to track whats going on, and this effect seems pretty consistent amongst all PCVR titles, even in the Steam Home environment this happens, although to a lesser extent. I'm using a Link cable that speed tests at 2.5Gbps.  I've tried the following to rectify it:

- Using the debug tool the manually lower the encode bitrate - it doesn't at all seem to effect it, whether I have it set to 20 or 500, it still hitches. Letting it dynamically choose doesn't work either.

- Setting the resolution to the absolute minimum, as well as trying to use 80Hz mode, (I tried 72Hz, but it makes me nauseous). I've also tried bottoming out all the settings in-game. These things serve to 'mask' the issue a bit as the performance is much higher, but it still keeps hitching

-I've reinstalled the software a few times, tried all different modes, different USB ports, 3.1, 3.2, isolated USB hubs -- nothing seems to make a difference.

- Giving the OVRServer realtime priority, opening the console, and any number of surface-level tips given on YouTube and Reddit.                                             

No matter what I do, this is what happens. Those yellow spikes are when the game locks up. As you can see, it happens in SteamVR Home too.





Community Manager
Community Manager

Hey there @Xerohan ! We hope you're having a great day today! Thank you for bringing this issue to our attention. We know it's no fun to not be able to use our devices to their full capacity so we would love to help getting this issue resolved for you. Luckily, we do have a couple of troubleshooting steps that you can try to fix the stuttering problem you are experiencing. If you haven't already, please try these following steps: 


  1. Verify there are no other IR emitters in the same room potentially causing interference.
  2. Check if the issue occurs while the device is on a flat surface without any vibrating objects nearby.
  3. Uninstall and reinstall GPU drivers,
    1. Close the Oculus app
    2. Press the Windows key + R on your keyboard to open the Run command
    3. Enter C:\Program Files\Oculus\Support\oculus-drivers
    4. Open oculus-driver
    5. Open the Oculus app and then try to connect your sensor again
  4. Reboot the PC

We've seen these steps help people out in the past with the same issue you're having. We're hoping that they will do the same for you.

However, if you're still having trouble after trying those steps, please don't hesitate to reach back out and let us know. We'll also be here if you have any other questions or concerns.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello there, thank you for the prompt reply -- unfortunately, this doesn't seem to have fixed my issue.

1. As far as I'm aware, there is no IR emitting devices in the room I use my Quest in. I moved my PC to a different room to ensure that, but the issue persisted there as well.

2. I wasn't 100% sure what you meant by this, as the display seems to turn off with the headset removed through Link, even when I have it set to stay on through the debug tool. I took the controllers out of the room, and sat very still for five minutes in Half-Life: Alyx. The graph was much more stable, but with those same hitches every few seconds. It hitches worst during movement, but its still present when stationary.

3. I followed these steps three times over, and it had zero effect.

4. Nope.

Just a side note, it seems that no matter what resolution, refresh rate, game or whatever it might be -- I always get 2.5% reprojection, caused by this stuttering.

Hi again, @Xerohan! Thank you attempting the previous provided troubleshooting steps. We would love to look into this further for you, in order to do so please send us a PM so we can further work on this issue by clicking here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. Hope to hear from you soon! Have an awesome day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Expert Protege

It seems that something is constantly polling the GPU. Something queries the status and then causes a spike like this.

If you have any RGB software running (Corsair iCue, Open RGB, Mystic Light...), please close it for testing. After closing it, the software mostly remains active in the background, so also kill the processes via Taskmanager.

If you have anything active besides fpsVR that counts your FPS or monitors the temperature of your graphics card, close this software to test it. This can be MSI Afterburner with RivaTuner Statistics Server, a tool from your mainboard manufacturer, any hardware monitoring tool, or any software for custom fan curves or water cooling control.

If you are using an NVIDIA card and have Geforce Experience installed, deactivate the in-game overlay in Geforce Experience.
Step 1: Right click on the Nvidia system tray icon and select NVIDIA GeForce Experience.
Step 2: Log into your NVIDIA account.
Step 3: Click the Settings icon (gear) on top right.
Step 4: In the GENERAL tab, turn off IN-GAME OVERLAY and exit.

If you have done these things, then you have eliminated some of the common causes for the kind of effect you are experiencing.

Best of luck!

Hi there @FUNtastic, thanks for the reply,

I think you very well might be right about the polling, as when I sit still in SteamVR Home, the spikes are extremely evenly timed, the problem I'm having though is figuring out what is causing it, as per your advice I've done the following:

- Disabled iCue
- Made sure that all overlays are disabled, especially the GeForce Experience one.
- Closed any and all unnecessary programs / processes that might be polling my GPU, though the problem remains.

Maybe something in my BIOS is causing this? Save for completely reinstalling Windows, I'm not sure where to go from here. 

Thank you for the suggestions!


Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?