Showing results for 
Search instead for 
Did you mean: 

Terrible PCVR Performance

Not applicable

Bought the Quest 2 a few weeks ago. I'm not going to get into how disappointing the out of box experience was because the post will be too long and bore everyone off.


My computer, my network and router, and gpu, are all configured perfectly. These aren't the issue. I have wifi 6, 1ms latency on airlink which cant be improved. I have some qualifications in networking so I started with a good understanding of this. 


Considering Oculus wasn't generous enough to include a cable for PCVR use, I used what is literally the world's fastest usb-c to usb c cable to connect to my computer. This still limited my i5 8600K 5.0GHZ, 16GB 4000MHZ Ram, and 1080ti 11GB to a whopping 5-30 FPS inside my headset, despite the fact that the PC is more than capable of achieving 120FPS on a VR headset. The games I tried were Skyrim VR, Fallout 4 VR, Blade and Sorcery, and Boneworks. I bought them all in anticipation - none worked.


The moment I launch link from the headset, whether this is from the cable or from air link, the headset basically **bleep**s itself. Welcome to about 5 frames per second on the Link Menu, the controllers have incredulous and unusable input and motion delay, and I literally cannot physically navigate the menu to change settings, launch a game, or make a virtual desktop because the lag does not allow it. When I did manage to get into a game, by launching from desktop, they were all stuttering horribly, and none would go above 30fps.  Is my headset meant to be basically unusable as soon as I launch the link interface right now? This is a menu, it's not streaming anything, why on earth am I turning left and right and literally seeing the matrix code instead of rendered frames? How is this advertised as a working feature? I can't bear more than 60 seconds of this without getting horrible eyestrain and wanting to be sick, because I am turning my head and it takes 10 seconds to register and move the display. 


I found virtual desktop, and paid for it. Ignoring link completely, I could now get 120fps in Blade and Sorcery without an issue. The performance overlay shows that my game, network, gpu, and cpu frametimes never went above 5ms. Amazing. Hardware wasn't struggling at all. It seemed the limiting factor in performance is literally the fact you have to use usb for a video cable (WHY?) or the limitations on SteamVR/Oculus Links networking capability. I've done multiple factory resets, I've trawled through settings relentlessly, and in weeks I haven't got either link method working properly.


Every game other than Boneworks/Blade and Sorcery pulls an error code Failed to create LibOVR Session -1007 through virtual desktop. These are the same games that run terribly, and they also are ones that want to use SteamVR. I have installed OpenComposite, Oculus Tool Tray etc and tried to improve performance with this and failed. In the last few weeks, I have managed to get fallout and Skyrim to launch through all methods: VD, Air Link, and Link Cable while repeatedly and unbearable fiddling with SteamVR and OpenCompensite but have not once got the FPS I should be getting in any form of connection. Virtual Desktop performance overlay is by far the best and the one time I did manage to it launched through VD, Skyrim showed that my network, gpu, and cpu frametimes were all still sitting at around 5ms, and the game itself it sitting at 50+, in the red and frames wouldn't go above 30. Navigating the main menu is harder than swimming a length of a swimming pool. HELP PLEASE?


Having to repeatedly go from a desktop, to the headset, to your phone for developer mode that constantly turns itself off and different settings scattered everywhere is a horrible experience, and is completely putting me off the Quest. All of the online materials seem years out of date.


























Level 13

So the 1080 ti is a great card for render, but encoder is lax on it I would venture out to say that possible you have the encode set to high.

Hey, thanks for the reply.


I'll fiddle with that. On Oculus Tool Tray, my encode resolution is set to 2016, encode bitrate is 250 to start todays experimenting. Does that sound around right for the card? I have double checked debug tool to make sure these are set.