Showing results for 
Search instead for 
Did you mean: 

Three dots problem, dark screen, fails "sensor check" yet there's clear evidence everything is worki

Honored Guest

I've been having problems with my Rift S.

Let me preface that I've had this headset for years and I've used it in many games and other applications, relatively well (the occasional unlplug the USB and re-plug little dance is a household tradition), and I've even played on it yesterday.

Today, I go to play a bit of Tetris and it works but it's facing the wrong way, so I reach out for my controller to recenter but the controllers 3D models seem to be floating under me, like a meter away. Sort of on the floor. I can see my hands down there, when I click buttons, but they're not floating in front of me as they should. So I restart my computer. Now, I get stuck in the three loading dots dark screen.

I followed a number of walkthroughs, fixes, workarounds, etc. But the problem remains and it's a very weird one:

Meta Quest Link shows everything is connected and green. But if I run the "Add device" wizard, it fails at the Sensors part and tells me to reconnect the USB

Tried all ports on my computer.

The weirdest thing is that the three loading dots are there, yet if I look down, I see the stupid controllers floating underneath me. If I grab one, the controller turns into a hand, and if I press buttons I see the fingers moving. The head IS TRACKING. The sound is working.

Any idea of what might be going on?

I've reinstalled the app, cleared the folders, rebooted, uninstalled the Oculus USB Hub from Device manager, tried all the ports, waiting 10 seconds between the USB being green and connecting the Display Port, tried another Display Port...


Community Manager
Community Manager

Hello there, @mariano.picco! We see that you have run into some issues with your Rift S. We understand that having these issues makes it hard to enjoy the awesome experience of VR, so we would love to look further into this for you in order to get you back to a smooth VR experience. In order for us to be on the same page, we would like to see what you are seeing when encountering this issue, and we appreciate you letting us know the troubleshooting steps you have attempted already. If you can, please send us a screenshot of the screen you are seeing when trying to use your Rift S. Once we can get this view, we can know what course of action is best for us to take next. We look forward to hearing back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I think I've answered all those questions on the post itself with the exception of the screenshot. 

I'm seeing the "loading" 3 dots in the headset. 

The headset fails the "add headset wizard" at the Sensors step

It makes no sense because, even with the blank screen and the loading dots, I can tell the head tracking is working because I can look around the empty loading room. The sound also works. These two things make me think that the USB connection is good

I tried using different USB ports

Uninstalling the Oculus software

Deleting all Oculus folders I could find


Using a different Display Port 

Several computer reboots

Read and followed steps found in differen threads such as:

Hi @mariano.picco. Thank you for letting us know all of those steps you have taken and for providing that link. We want to check a few more things to see how we are going to proceed towards trying to solve your issue. Can you confirm that all your drivers are updated on your PC, especially your display drivers and USB drivers as well? Make sure you have also updated your headset to the latest version. We eagerly await your response. Talk soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

All drivers are fine. The thing was working and I rebooted the computer and it stopped working. Everything is working. I just see three dots and the controllers on the virtual "ground", responding to my touchs but not moving. 

The firmware version on the headset states 2.2.0

I entered Meta Quest Link into Beta mode. 

Theres an OVRServer window now showing up with a lot of debugging information:




We appreciate you so much for your cooperation and detailed messages, @mariano.picco!


We would like you to try this troubleshooting to see if we can help you get the Sensor Check message fixed. This can also determine if the controllers will go back to their normal positions. 

  • Reseat USB cable from the PC
  • Reseat cable from the headset
  • Reboot the PC
  • Lighting
    • Is the play location well lit? (Turn on more light)
    • Is the play location too bright? (Adjust the intensity, or amount of light
    • Texture is also a factor with tracking. If there is not enough contrast between objects in the room, this could lead to tracking issues.
  • Check your Windows camera settings:
    1. Open your Windows settings.
    2. Click Privacy.
    3. Click Camera.
    4. Change the Allow apps to access your camera setting to On.
    5. Once you've updated your settings, unplug the headset cables from your computer and plug them back in
  • Open device manager
    1. Go to Universal serial bus controllers
    2. Uninstall/remove the Rift S sensor items listed.
    3. Once removed; click scan for hardware changes at the top of device manager and wait a few minutes for the items removed to come back.

Please let us know if you still see the sensor check message. We hope to hear back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @mariano.picco!

We're just circling around to see if you need any more assistance from us. If so, please feel free to hit us up again regarding your issue. If not, don't be afraid to reach out to us with any questions, concerns, or issues.


We hope to hear back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?