cancel
Showing results for 
Search instead for 
Did you mean: 

USB 3.0 issues with Quest 2

jonny_b_1990
Level 3

I see lots of similar posts about things surrounding this issue but they usually get brushed off, I am hoping that making this post and outlining what I have done so far it may finally prompt a fix.

 

Essentially the issue is that when connecting with a USB 2.0 connection, the link is completely stable, it reliably connects for several hours and even if the headset is removed and left to "sleep", it reawakens and is still successfully connected (team events in iRacing if you're asking). When using USB 3.0 however, the exact opposite is true, generally speaking in the best case scenario, when keeping the headset awake the whole time, I can sometimes get an hour before a disconnect, however, nearly every time it goes to sleep, it disconnects and sometimes the connection will be lost within minutes of launching with no explanation.

 

For a bit of history, over the course of trying to find a solution to this issue I have: Used a USB A-C 3.0 cable, 2x USB C-C 3.0 cables (including Oculus' own), a USB A-C 2.0 cable, a USB C-C 2.0 cable, replaced my PC's motherboard with a Asus Prime Z-390A, so I would like to think this firmly rules out the frequently posed "solutions" such as better quality cables or using different ports. I have also tried resetting experimental features as I read that sometimes causes issues but this didn't have an effect, nor has making sure that video drivers and my motherboards firmware are up to date, disabled legacy USB support in my bios settings or ensuring there is no power saving settings activated on USB ports.

 

The most frustrating part of all is that recently I did a factory reset of the headset 'cause I couldn't think of any other fix and seemingly this finally gave me a stable USB 3.0 connection using the official cable, which not only lasted until I disconnected it (several hours), but also through cycles of sleeping and waking the headset. I then didn't play for a week and Oculus app version 38.0.0.51.727 (38.0.0.51.727) / headset version 38.0.0.63.727.351486028 installed themselves and now I'm back to the same problem of 3.0 not working and 2.0 being absolutely fine, the factory reset and experimental features reset has not had an effect this time.

 

To be clear, there have been no hardware changes at this time so given it did work as intended previously, it has nothing to do with cable quality or any mechanical issue. Any other insight of fixes that I have not yet tried would be appreciated, although mostly an indication that this is being sincerely looked into as a known issue not just brushed off as an outlier. Please let me know if you need any additional information and I'll post when I can.

1 ACCEPTED SOLUTION

Accepted Solutions

Finally I got to the bottom of it. If you connect to the PC and it shows you are usb2 just pull the plug out of your headset and reconnect. Seems to be fine for me after that. Good luck people!!!

View solution in original post

34 REPLIES 34

MetaQuestSupport
Community Manager
Community Manager

Hi friend, we've noticed that you've encountered some issues connecting your headset to your PC using the Oculus link feature. Rest assured, we heard your voice and were here to help! We'd like to also thank you for taking it upon yourself to perform some troubleshooting steps to resolve the issue; you are amazing! We'll need to gather your log files to review the internal workings of your computer to see if that could be causing these issues. Please follow up with us with these important details on our official Oculus Support page so that we can continue to assist further! 

jonny_b_1990
Level 3

Pleased to say we have a fix:

Try to also install the latest Oculus drivers by following the steps below:
Close the Oculus app.
Press the Windows key + R on your keyboard to open the Run command.
Enter C:\Program Files\Oculus\Support\oculus-drivers.
Open oculus-driver.
Open the Oculus app and then try to connect your headset again.

Perhaps a "check for updates" button in the app, would have saved me 15 months of complaining and saved me buying a cable with 400% markup on it!

NikZ6
Level 2

Hi jonny_b_1990, thank you for the information you shared.

I tried to install the latest oculus driver following your instructions, but I don't get any notification or message about the driver has been updated / not. And when I tried to use the oculus link cable with type c-c (USB 3), it still randomly disconnect (within minutes, sometimes 5, 10 or every 20 minutes), while using cable type a-c (USB 2), it is stable for hours of playing.

 

Should any message/ notification pop up when you open the oculus-driver.exe (to update the oculus driver)?

How do I know if my oculus driver has been updated? Anywhere to check the status/version? Or does "oculus driver version" basically means "Oculus app version" ?

And does that mean for the USB 3 to be running stable, the Oculus App and Headset version must exactly match? 
 

It would be great if you could share your experience on this. Thank you so much. 

Hi Nik,

 

Sorry for the radio silence. No notification gets shown but it clearly does something as if you immediately try to launch the desktop app it shows a loading bad that it usually doesn't.

 

This also wasn't any where near as permanent a fix as I had hoped, V39 has locked me into 72hz so perhaps I've just got one of the "dud" ones.

Hey, first time replying to somebody on this website. Lucky you!

Anyways I SOMEHOW managed to fix this for myself magically and it's the most stupid thing yet. IT DOESN'T EVEN INVOLVE THE SOFTWARE. So forget drivers forget anything (Actually maybe don't if anyone has that issue.

For me, the USB 3.0 worked for a long time for me and magically became 2.0 after like a few days ago. Now I decided to play with the cable see if it will tick anything (btw for reference I'm using a KIWI cable) After the 2.0 connected I took out the big one that goes into the computer and back in. Turns out the quest doesn't connect unless the one connected to the computer is plugged in first. After that put in the USB C in the quest and boom. It turned into 3.1 gen 1. It seems the quest has a major software issue and just meddling with the cables connecting sequence seems to tick the 3.0 mode back on.

Look, this probably won't work for everyone but I did this 3 times with amazing success so far. If this works for anyone I will be extremely happy cause this bug is extremely annoying.

PS: When I flipped the USB over too it seemed to connect to the 3.0 mode aswell. So flipping the cable does work and it's more effective, but doing my sequence above makes it so the 3.0 works in it's correct spot if it's a sideway cable.

Hi Jonny, I too am having USB3 connection problems. Up until 2 days ago it worked fine. I tried reloading the driver as you suggested. It worked for about 5 mins before it came up with USB2 connected. I'm wondering if this is a Windows 10 update problem?  I tried different ports and opting in and out of beta test channel, but that hasn't worked either. I will try reversing the USB plug as suggested. To get round it I managed to get the airlink to work. But I get better performance on the cable.

Nah that didn't work either, I rebooted a few times then it started working. Of course the next day it didn't.

Finally I got to the bottom of it. If you connect to the PC and it shows you are usb2 just pull the plug out of your headset and reconnect. Seems to be fine for me after that. Good luck people!!!

Exspects
Level 2

Hey, I've recently discovered this linking issue but I can't seem to find a work around even tried your unplug and plug back in method and it's the same thing, what could really be causing this as my usb isn't damaged and came with my package