Showing results for 
Search instead for 
Did you mean: 

Unable to AirLink Quest 3, listed as "Not Connected". Have three loading dots if I use a cable

Honored Guest

Hello, so I had a quest 1, got a quest three and it works great natively, works great with Virtual Desktop and SteamVR. It cannot connect or run with meta quest link at ALL, whether through a cable or air link. I have tried every solution I could find: removing my old quest from the app, updating drivers, uninstalling app and redownloading it, restarted PC and headset multiple times, restarted meta quest link in beta setting multiple times, enabled OVR and other Oculus app tools through my Firewall, set my network as private.  

I would like to use the Puppis 1 that I got and connect via airlink like it works with virtual desktop and steamVR, but I swear I am going insane trying to get it to work. I can not find a single solution that works for me on other forum or reddit posts. 


Community Manager
Community Manager

Hey there @Massimo_MD! Thank you so much for reaching out to us! Trying to connect to PCVR but encountering issues is the worse, so let's get to the bottom of this! To ensure we are not running around in circles, we'd like to ask you a few questions.

  • Would you please provide your computer specs?
  • Do you have the dual band feature enabled on your router? (Disabling may prevent the headset from joining another channel which can impact the WiFi signal)
  • Are you using WiFi extenders? 
  • How close are you to your router?
  • Please list any other troubleshooting steps you have performed 

We appreciate you taking the time to get this over to us, we're looking forward to your response!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

Hey again @Massimo_MD! We just wanted to circle back around to see if you still needed assistance. If so, please reach out at any time!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks for the response, been busy with work all week so I am late to replying...

  • ProcessorAMD Ryzen 7 3700X 8-Core Processor
    Video CardNVIDIA GeForce RTX 2070
    Operating SystemWindows 11
    RAM16 GB
  • I am using the PrsimXR Puppis S1 dedicated router, which apparently has dual band feature, but does not have dual band when connected to the quest 3, so i just have 5GHz frequency.
  • No wifi extender (except I use the Puppis S1 as described). Unfortunatley, I cannot tell if the Puppis S1 is getting internet directly from the PC's ethernet connection via PC sharing or if it is using the wifi connection to then generate its own internet. Like I said though, this setup works great for VirtualDesktop and SteamVR, so I am wondering why QuestLink would specifically not work with this.
  • Very close, its on my PC desktop, and I either use the Quest in the same room or one room over in my apartment. 
  • Aside from the listing off I did in my OP, I don't know what else to mention. I feel like I have tried everything mentioned in a various number of reddit threads or support forums on here, and have not found many where the original thread creator actually had their connectivity fixed, at least in a way that also worked for me

Honored Guest


Additionally, figured I'd verify this here. Do I have to run the Meta Quest Link as an administrator every time I use it? It came downloaded like this by default (see image). It's a little annoying to always hit "Yes" or "allow" to let the program run after clicking on it, and I was wondering if this is impacting the quest 3's ability to connect with it.

Hello @Massimo_MD. Thanks for providing us with the specs needed to look further into the situation. Looks like everything is in alignment as far as compatibility goes. We recommend the items below to repair the connecttivity and performance of your PC using Quest Link. After applying the first set of steps, the remaining items will help us ensure the success of everything else running smoothly. 


  1. To make sure the connection is properly established:
    1. Open the Meta Quest PC app on your computer.
    2. Turn on your Quest headset.
    3. Plug your USB 3 cable into a USB 3 port on your PC, and then plug the other end into your headset.
    4. A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
    5. When prompted to Enable Meta Quest Link, select Enable to begin remote rendering using Meta Quest Link.
      Reference: Set up Meta Quest Link
  2. Ensure Air Link is disabled in Settings on the headset.
  3. Repair the Meta Quest PC Application. This is accessed by re-running the Meta Quest setup file. If the setup file detects that Meta Quest Home has been installed, partially or fully, Repair will appear in the list as an option. Repair is unlikely to address any app-specific or error messages related to hardware components.
      1. Go to and click Download software.
      2. Select Repair.
        1. If Windows asks you if you’re sure you want to open this file, click Yes.
        2. If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.
        3. If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
        4. Please remember to re-enable your antivirus software once you've completed the repair.
      3. Allow the repair process to run, download and install.
      4. Launch the Meta Quest PC app.

After the above steps, continue as follows: 

  1. Install the latest Meta Quest drivers
  2. Confirm the customer’s USB power settings. (If graphics cards or Windows needs an update > proceed with needed changes and restart PC after.) 
  3. Check for Selective Suspending (Make sure it's disabled)
  4. Enroll in/opt out of the Public Test Channel (PTC - Enroll in this test). 
  5. Cold start the Quest headset
  • With your headset on, hold the power button on the right side of your headset down until you're prompted with a shut-down screen.
  • Select Shut Down and wait a few minutes before you reboot your Quest headset. 

        6. Collect and review Oculus Diagnostic Logs:

  1. Setup Logs
    • On your PC, press the Windows Key + R on your keyboard to open the Run window.
    • In the Run window, type %LOCALAPPDATA%\Oculus\ and press Enter.
    • Locate the OculusSetup.log file and save it.
  2. Meta Quest Diagnostics Logs
    • Find your Meta Quest installation directory (C:\Program Files\Oculus if installed on the primary hard drive).
    • Navigate to Support and then oculus-diagnostics.
    • Double-click OculusLogGatherer and wait for an executable to appear.
    • Select Get All Logs.
    • A .zip file containing the logs will be saved to the desktop


We know this may appear extensive so if you need any extra clarity or a breakdown of any of the steps, please let us know. By going through these steps we can start to cross out things that could pose as an issue in all steps of the process for you. We hope this is as useful as we intend it to be. Looking forward to updates from you on the outcome of the applied steps. Hope to hear from you soon. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey @Massimo_MD.  We're just checking back in with you to see if there's any updates on the issue you're experiencing and if you still needed assistance. We're here and open to helping you if you have any further questions as well. Hope to hear from you soon.



If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

Would I be able to share my logs with you? I tried the steps you outlined, and my quest actually could connect via cable, however, the "usb cable test" "Was not able to start". I could though, enter into quest link. Air link still does not work. 
I completed the initial 1-3 steps, and completed 1 and 5 and 6.1 (saved log files) of the other steps you outlined. I am weary of the PTC because of how much I am struggling to connect with the public software. I don't know how to do 2 and 3. But if I can share my logs with you, will that expedite this process?

Thank you for getting back to us @Massimo_MD! We appreciate you going through our recommended steps. We would be happy to look into this further and get some eyes on your logs. Since the logs contain detailed information about your PC, please contact us privately by sending us a message from our Profile Page. Select our name to visit our profile, and then click "Send a message" while logged in. We look forward to hearing from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey again @Massimo_MD! We just wanted to follow up and see if you still need assistance with this. We would be happy to review any logs you provide and are available to message from our Profile Page at any time. Just let us know whenever it is most convenient for you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?