Showing results for 
Search instead for 
Did you mean: 

Unable to access my old account after merge.

Level 2

When starting my oculus 2 I was prompted to update my device and then merge my facebook account with the new Meta account. I had some trouble but managed to create one but I couldn't select my old name, I had to add a "_" and this account is seen as completely new. All my old games and progress is gone and the headset keeps prompting me to type in a code at "" and then I  get a green checkmark on the website but in the headset it says that I'm trying to login using a different account from my original.

When I'm then prompted to go to "" and logout I tried to login with my facebook login for my old account but it seems to be linked to this new account. Is there anything I can do to get my old account back?


Community Manager
Community Manager

Hey there! That's not an experience we like to hear. We'd love to help.


Is it multiple apps or just one app?


Can you please try the following:

  • Logging out of all devices and then trying to log back in.
  • Switch the headset off
  • Log out the Facebook account on the mobile phone
  • Log back into the Facebook account on the mobile phone
  • Log out the Meta Quest application on the mobile phone
  • Log back into the Meta Quest application on the mobile phone
  • Uninstall and reinstall the Oculus app?
  • Restart the headset.

Please let us know if this works for you.

Not applicable

I have the same problem and your “solution” is worthless. This device blows now. Next step, delete all accounts and sell vr. 

Not applicable

I have the same problem. Delete everything and sell. Much better option. 

I lost everything this is bs cant gain access to old account

@Whitey-720 Sounds to me like you might have just made a new account instead of merging over with the current one. 


Sometimes people use Facebook to login when they aren't linked originally, so that could be the case with your account. 


Have you tried to login via email?


If you hit up support with either a PM or Support ticket, I'm sure they'd be glad to look at that and see what they can do. 

Thx for the sign to sell my oculus this **bleep** ain't working ur response is worthless so next time actually help uve tried all of this and won't let me create a meta account just the check mark on my phone but the error on my Oculus this unacceptable I'm done with this company fix your **bleep** 

Having same problem. Cant access oculus account. Password reset just resets my meta password. Im using a lawyer for some other issue and guess will get him on this and make a facebook group for everyone having this issue to make a class action lawsuit.

Hey @nyctattoo! We noticed that you are experiencing some issues with getting logged into your account after creating a Meta account. We hate to hear that any of our users would be experiencing some like that and we'd love to help you get this issue sorted out! Oculus accounts are being migrated to Meta accounts which will give our users more flexibility and control. We want to make the account setup process as easy as possible and we'd recommend clicking here for further information regarding Meta Accounts. We'd recommend trying to login using your email/password combination. If you are still having issues with getting logged in, please reach out to us in private message so that we may locate and review your account. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

Hey there, @nyctattoo! We just wanted to check in since we haven't heard back from you yet. If you'd still like help with this just let us know, we'd be glad to help out!