Showing results for 
Search instead for 
Did you mean: 

Unable to connect phone app to the Quest 2

Honored Guest
Hello, I've recently acquired my new Quest 2 and am struggling with the setup.
My smartphone is old and I suspect it is the problem. It's a Moto G with Android version 5.1. I've seen that the Oculus app is compatible with Android 5.0+ so I hope this is fixable because buying a new phone isn't appealing to me currently. 
The specific problem appears to be with the location connection during the pairing. Even with the location on, the Oculus app asks for the location like it isn't. I've uninstalled the app and reinstalled it but it hasn't affected the issue.
Any help would be super appreciated thank you!

Honored Guest
Did you get a solution on this?  I've been trying to set up with a Samsung Galaxy Core Prime running Android 5.1.1 and when you say "Even with the location on, the Oculus app asks for the location like it isn't", it sounds like we're having the same problem.

I've been talking to Oculus Support about this since November 27th.  After a number or reboots (phone, router & Quest 2), uninstalls & reinstalls of the app, and setting up a wi-fi hotspot on my phone (they thought maybe my router was the problem), they're currently suggesting I try a different phone.  So I've ordered a Nokia 1.3 (runs Android 10 and cost £65 from Currys) in the hope that'll sort it.

I'm going to be a bit miffed if it doesn't.  I would have hoped that by this point in time Oculus Support would KNOW if there was an issue with 5.1. rather than just guessing... but apparently not.  😞

Honored Guest
I'm having the same problem with a Galaxy Prime running 5.1.1. Location, Bluetooth, and wi-fi are all on. Location works in google maps. When I try to pair on the phone a "Location access is needed pops up. Tapping on the "Next" button does nothing except blink.
Seems like a problem with Oculus App and Samsung. Any work arounds? I'm stuck.

Not applicable
Seem to have the exact same experience as user_939340911966710 said:

When I try to pair on the phone a "Location access is needed pops up. Tapping on the "Next" button does nothing except blink.

Oculus App Version on Android Version 5.0.1 with Location, Bluetooth, Wi-fi, and mobile data all on.  Unable to connect to Oculus Quest 2 headset....  The headset shows up in Bluetooth scan, but wont pair, "Unable to communicate with Oculus Quest 2.  The Oculus App says it needs Location Access, which is on and permission granted but Tapping "Next" does nothing.

Honored Guest
same problem, just cant get past the location access part on amazon fire hd 10 tablet.  next button does nothing! smh
has this been solved yet???  i am able to do it with my dad's smartphone doe.  it's so annoying we have to go through this step just to set it up.  why not just allow us to set it up from within the headset without using a mobile device?

Honored Guest

Same issue here. Android 5.1.1.

And update from support?

Did we buy a $400 paper weight?

Not applicable

Same here, Been trying to find a way around this issue for 5hrs now. I for the life of me can't understand why it needs to be paired to a phone to work at all!


Honestly, screw Oculus at this point.


Headset wifi was dropping, so I decided after nothing else worked that I'd do a factory reset, and if that didn't work I'd put in a support ticket which would inevitably be ignored. Woe be the fool that tries to fix something on their own though, because of course to get the headset to a workable state, you have to have the app.


So, I open the practically unused app thinking it'll be easy, it worked before after all, with the same phone and all that. But oh no, when I click the button, obviously because of some crap update they've done, it doesn't bloody work.


At this point I genuinely hope Oculus fail, because between the fact that there's been NO official word on this thread regarding this issue, nor has it been fixed in like 9 months, means obviously they just don't give much of a crap.

I've put in a support ticket, but from what I've seen, I highly doubt anything useful will come of it, probably just copy-pasted useless support information that goes nowhere, does nothing, and leaves me throwing this £399 pile of plastic out the window and deleting anything that Facebook has its grubby paws on.


The fact that you have to pair it with a phone is just silly and feels like it's facebook just trying to find more avenues to spy on consumers.

Honored Guest

Same problem for me.

Android 10


edit: i restart the app, it work... dont know what was changed


Same, this is nuts.