cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to download Oculus app

laggerball
Explorer

Screenshot 2023-08-23 at 9.30.11 PM.pngWhen I try to install the oculus app, I get this message. I am running Parallels on a Mac Mini M2 with 32GB of RAM. I have tried many "solutions" but it hasn't worked.

9 REPLIES 9

MetaQuestSupport
Community Manager
Community Manager

Hey there, @laggerball! We see you're experiencing some trouble installing the Oculus Desktop application. We know how appreciated this PC VR feature is and certainly don't want to have to continue dealing with this problem! With this in mind, we'd like to share some insight into why this issue may be occurring. There are certain requirements that need to be met in order for a successful desktop download, one of those would be that the PC will need to be a Windows computer. We noticed you mentioned using a MAC computer for this installation, and this could certainly be the cause of this issue.

 

The PC itself must also be compatible to handle the PC VR connection for the Link or Air Link connection to function properly, which includes having a compatible processor, graphics card, memory, operating system, and USB port. Being as the Mac devices run on iOS and do not have the same PC components as standard computers, it is currently incompatible with the Oculus Desktop application. Although that Parallels program is able to run Windows on the device, the Mac operating system and system components are not compatible with Oculus services and devices at this time. For more information on this matter, please check out this article which mentions at the very bottom that a non-Mac computer will be needed to install the Oculus Desktop app, as well as those needed PC requirements at the top.

 

Although we know this is hardly the most ideal news to share, we're glad to be able to clear this up with you! Please let us know if you have any further inquiries and we'll be glad to assist further! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks. After a while, I gave up trying to run windows on that computer when I found Oculus can’t pass the graphics requirements with the silicon graphics. I used a different computer (a Mac) with an Intel i7 and a AMD Radeon 560x Pro GPU (which has sucessfully run Air Link before, but not the fastest) And got through installation and setup of the program with no issues whatsoever. When I boot up my headset and go to Air Link (or Oculus Link, but I haven’t tried it with an Oculus brand cable), I see a black screen all around with 3 dots, signifying loading. I have tried many things, including repairing the app, all the way up to factory resetting the console, but none have worked. Hopefully somebody can find a fix.

Thanks for getting back to us, @laggerball. While the Mac Mini M2 isn't recommended for PC VR use, your other computer seems to be up to speed. However, there is a known issue with air link at the moment that our engineers are working to get resolved. We'll list some steps below for you to try out that's helped out some other users, give them a try and let us know how it turns out! 

 

  • Disconnect the Rift/Link cable from the computer.
  • Disconnect your computer from the internet.
  • Backup any necessary content.
  • Reboot into Safe Mode.
  • Uninstall Oculus PC app using the Control Panel.
     
  • Delete all Oculus folders from the following folder:
  • C:\Program Files
     
  • Remove any Oculus folders from the following locations:
  • C:\Users\YourUserProfile\AppData
  • C:\Users\YourUserProfile\AppData\Local
  • C:\Users\YourUserProfile\AppData\LocalLow
  • C:\Users\YourUserProfile\AppData\Roaming
  • C:\OculusSetup-DownloadCache
     
  • Restart your computer in normal mode.
  • Reconnect your computer to the internet.
  • Install Oculus PC app again using the setup tool from our website here.
  • Reconnect the Rift/Link cable and re-test the headset.
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Sadly, this did not work. I would like to note that I get a notification when I try to connect to the headset on my computer which basically says to visit the support page. In addition, I can’t use cabled link since I don’t have an Oculus brand cable. I still get the black screen and 3 dots.

Thanks for getting back to us! After double checking our list of Requirements for Air Link/Link, while the hardware seems up to speed the OS is not. Operating systems we support are currently Windows 10 and Windows 11. While the headset may have worked in the past, we aren't able to guarantee any positive results from troubleshooting if the Operating System doesn't meet our requirements. We know this isn't the response you had hoped for, and we appreciate your understanding of the situation. We hope you enjoy the upcoming weekend! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I’m using an X64 version of Windows 10, on hardware completely (as you said) supported. I don’t understand how the OS rules out link. Thank you.

Thanks very much for clarifying, we didn't see where you mentioned installing Windows on your Mac. If air link still isn't working, then it's likely due to the known issue we mentioned that our engineers are working on. We'll be sure to let everyone know as soon as we get some good news from their team about a solution. We appreciate your patience while we get this resolved! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you so much for the help! Just to clarify, in an earlier post, I mentioned the fact I’m running bootcamp on the Mac, which is just Apple’s nickname for “running windows natively on the intel processors”. Thank you so much, and have a great day.

Not a problem at all, @laggerball. We must have missed that part about bootcamp, that's our mistake. As soon as we get some good news from our engineers we'll be sure to reach out and let everyone know that it should be resolved. Until next time! Enjoy the upcoming weekend! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?