cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install Oculus desktop app

Rawrbear89
Honored Guest

Hey,

Just got my Quest 3 and have been setting it up. I've attempted to install the Oculus desktop downloaded from here: https://www.meta.com/gb/en/quest/setup/
There wasn't a Q3 option so I've selected the Q2 download link.

When I've ran the Setup.exe I get the welcome page -> click Get Started -> I get the Review Terms and Conditions with 2 separate links which I can open without issue -> click Agree and then I get an error "Can't connect. Looks like we can't reach the Oculus server. Please check your connection"

I've restarted my pc, ran the install as admin, disabled windows firewall. I'm not running any additional AV software or any VPN services which may be impacting.

Looking at the log file for the install there are a few errors and issues called out:

 

[Error] [10/11/2023 00:04:46] Exception setting locale!
System.TypeInitializationException: The type initializer for 'System.Web.Util.Utf16StringValidator' threw an exception. ---> System.Configuration.ConfigurationErrorsException: Unable to retrieve configuration section 'system.web/sessionState'.

[Error] [10/11/2023 00:04:46] Error fetching / parsing config.\nSystem.AggregateException: One or more errors occurred. ---> System.Configuration.ConfigurationErrorsException: Unable to retrieve configuration section 'system.web/sessionState'.

 

 

and what I suspect is the culprit

 

[Debug] [10/11/2023 00:04:56] Starting preflight checks.
[Debug] [10/11/2023 00:04:56] RunCheck 'Dawn.Preflight.ConfigInitialisedCheck' failed.
[Error] [10/11/2023 00:04:56] Aborting installation due to failed preflight check.

 

 

What should I do to resolve this? The threads I can find on the issue suggest fixes that don't make sense in my situation (freeing up disk space or installing a .NET framework that's been superseded by the latest versions I have installed on my machine).

 

Edit:

So I tried to install the software on my wifes PC (her hardware likely won't support it but I was interested to see if she would have the same install issue). On that I can get onto the install location page that should appear after the T&Cs. Looking at the install log she didn't get the issue with "Exception setting locale!". I've no idea what the error means unfortunately and so far nobody has been able to offer any help.

5 REPLIES 5

Fighter_of_Foo
Explorer

Did you ever get this resolved?

I'm having almost the exact same issue, and noting I've tried has worked.  The only other suggestion I've seen is to create a new user account on my computer and try to install it there (some people said that works, but I don't see why it would).   

 

Kind of. I went extreme with it and wiped my pc and reinstalled windows. It was long over due and I had been thinking about it prior to this but not the best solution I admit. After reinstalling though it went through without a single issue.

Thanks.

I did get it to start to install, but the connection stalled at 96%.  Wasn't anything I did to get it to start as far as I know. Frustrating.

Maybe I'll try to create a new user account and see if that will help (my computer is only a few weeks old so I don't think a windows reinstall would help me).

 

Hey @Fighter_of_Foo, we'd love to help get you back on track to enjoying the wonderful world of virtual reality. We understand you're experiencing some issues installing the Meta app after recently cleaning your computer's files. We'd like to provide a few troubleshooting steps, as there may still be data on the computer.

  1. Disconnect the Link cable from the computer
  2. Disconnect your computer from the internet
  3. Backup any necessary content
  4. Reboot into Safe Mode
  5. Uninstall the Oculus PC app using the Control Panel
  6. Delete all Oculus folders from the following folder:
    • C:\Program Files
  7. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
    • Note: The AppData folder is usually hidden. Use these steps to access AppData.
      1. Press Windows key + R to launch the Run dialog window.
      2. Type %AppData% in the Run box and click OK or press Enter
      3. File Explorer will launch to the AppData\Roaming subfolder.
      4. Click AppData in the File Explorer address bar to show all three subfolders in the AppData location.
  8. Restart your computer in normal mode
  9. Reconnect your computer to the internet
  10. Install the Oculus PC app again using the setup tool from our website here
  11. Reconnect the Link cable and re-test the headset

If the issue persists, please do not hesitate to contact us. We look forward to hearing back from you! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there! We wanted to follow up with you and see if you had been able to perform the steps we provided, or if you still needed assistance with your issue. Please reach back out to us and let us know if we need to look into this issue further with you or if the issue is resolved. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Get Help
Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

Check out some popular posts here:
Getting Help from the Meta Quest Community
Tips and Tricks: Charging your Meta Quest Headset
Tips and Tricks: Help with Pairing your Meta Quest
Trouble With Facebook/Instagram Accounts?