cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to launch air link

LostManAbroad
Honored Guest

So my Oculus 2 has never had problems with connecting to my computer via the Air Link feature. Then a few days ago, I was online with my girlfriend watching a movie in Bigscreen and suddenly the Air Link disconnected. When I tried to reconnect I couldn't because the Launch button was greyed out. My headset still showed my computer but I simply cannot Launch the Air Link.

Things I tried: Restarted the headset, restarted my computer, completely deleted all files for Meta Quest Link app on my computer from C drive and then reinstalled app, factory reset my VR headset & deleted and reinstalled the app on my phone.

None of it worked and when I factory reset the headset and reinstalled the app I then couldn't get my phone to pair with the headset. I then sent an email to Meta Quest support. They wrote back pretty fast and asked some questions, all of which I answered and replied to the same day. They didn't bother getting back to me after that.

3 REPLIES 3

LostManAbroad
Honored Guest

Today when I woke up I tried again and I managed to get the app on my phone to pair with the headset. I re-setup my play area and then tried the Air Link and it worked again. Finally!! So then this evening I started up the Air Link, started up Bigscreen and started watching a show that was on my PC with my girlfriend. Part way through the show the Air Link cut off and I am back to square one. My headset will no longer connect to my PC. What the hell is going on? Am I going to have to make factory resetting my headset a daily thing now?

MetaQuestSupport
Community Manager
Community Manager

Hey there, @LostManAbroad! We definitely want for you to be able to use your headset in the way most comfortable to you, and that can be hard if your Air Link is giving you trouble! You did mention reinstalling the Oculus PC app, but we want to make sure that was done in a comprehensive fashion to clear out all of the old data that could be causing issues. Here are the steps to get that done:

 

  1. Disconnect the Rift/Link cable from the computer
  2. Disconnect your computer from the internet
  3. Backup any necessary content. You can find steps on how to do so by clicking here.
  4. Reboot into Safe Mode. You can find steps on how to do so by clicking here.
  5. Uninstall the Oculus PC app using the Control Panel. You can find steps on how to do so by clicking here.
  6. Delete all Oculus folders from the following folder:C:\Program Files
  7. Remove any Oculus folders from the following locations:
    1. C:\Users\YourUserProfile\AppData
    2. C:\Users\YourUserProfile\AppData\Local
    3. C:\Users\YourUserProfile\AppData\LocalLow
    4. C:\Users\YourUserProfile\AppData\Roaming
    5. C:\OculusSetup-DownloadCache
  8. Restart your computer in normal mode
  9. Reconnect your computer to the internet
  10. Install the Oculus PC app again using the setup tool from our website here
  11. Reconnect the Rift/Link cable and re-test the headset

If that does not get things working more smoothly, let us know and we'll see what else we can try.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey, we wanted to check back in to see if you needed any further assistance. Please don't hesitate to hit us up!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?