Showing results for 
Search instead for 
Did you mean: 

Unable to link headset with mobile device

Level 5

My original oculus quest 2, developed a fault, where the battery was not holding its charge, 85%, 81%, 79%, 75%, 71%, 68% - over 24hrs

After contacting the Support team, they agreed it had developed a fault and I returned it back for an RMA replacement. This replacement arrived with me on Thursday. However, whilst I have been able to delete my original headset from my account, I am unable to pair the refurbished unit.
I have been trying now for two days. I had a support call with your technical team who advised me that this is an ongoing issue and developing situation which the engineers are working on and has been going on several weeks. I have tried to use an apple, iPhone, and iPad, and even a Samsung galaxy android phone.
My account was credited with £30 due to the inconvenience and compensation to buy Software or games - luckily I still have my quest one which is still registered and working 100% perfectly.
However, at present I am unable to pair my refurbished quest 2 headset with my account, when I asked the technical team if they could automatically add it from their side, I was told that this was not possible and it would only work if I logged into the app and added the device here. I have tried everything including deleting the app, wiping the headset– which was already wiped, switching Bluetooth on and off, deleting the app and reinstalling it, logging in and out my account nothing has worked.

It would make more sense if a link was sent to those affected customers, which they can click on, which prompts them for the Bluetooth code, which then automatically added to their account. This would then allow a workaround solution until the software and hardware is fixed.


From what I understand, this has been going on for several weeks, so I have no idea how this is affecting new customers who are buying a brand-new machine, certainly Meta need to get on top of this and issue a workaround as a temporary measure until the hardware problem can be fixed.


I now have a replacement quest 2 which I am unable to link to my account or even use as I cannot get past the pairing problem.
Prior to this, I had a quest 2 that was linked to my account worked fine but had a defective battery,

Meta need to find a way to allow customers to link the headsets to their accounts, this would clear any backlog while the hardware problem is being resolved.


Level 3

my replacement does not pair either and people have been complaining about this since July.  I was on support for hours yesterday (the chat kept dropping) but all told me the same thing you were told. "we are aware of this and and working to resolve it.  At least you got a credit I can't even suspend the apps with subscriptions.

Everyone was too busy rushing to sell their quest 1  to buy the quest 2. I wisely decided to keep my original quest 1 and buy the quest 2 I’ve never had a battery fault with the original Quest - sensibly also buying a spare left and right controller from new. It never give me any problems and luckily I bought it with a larger memory expansion.

I think Meta/oculus need to knock up a simple webpage which they can send to individual customers with a personalised URL who are having these problems which will then prompt them for the pairing code and then automatically link it up to their account - they could do this much quicker than three months!
The other option of course will be to allow the customer services team to physically take the serial number via phone or online chat to link it to the users account. 
I’ve not seen any public announcement from their website regarding this issue and even giving updates as to how long they think it will be before it’s resolved.
Normally on a status page, you would put

‘Some customers are experiencing problems connecting their headsets via Bluetooth.

we are aware of the problem, we apologise for the inconvenience and our engineers are working on it, we hope to have it resolved by such and such a date. ‘

Hi Ebi, got mine to work now, was sent a very reliable link from a user in the Quest 2 forums, and he offered to assist, but due to the time difference (he is Pacific Time and I am BST) he posted the link. Needless to say it worked fine. If you are in a time zone which we can share or meet so i can help I will do my best.