Showing results for 
Search instead for 
Did you mean: 

Unable to pair phone to headset

Level 3

I am trying to access the quest 2's settings via my phone to turn on developer mode, and I found out my oculus isn't registered under my devices. I went through my settings on the headset itself to find the pairing code, and went through the process of pairing the headset like I just got it out of the box. Every time I put in the code, one of two things happen; It will read "Pairing Your Quest 2" for about 10 minutes, or it will say to "try again later". Also tried pairing it through Oculus Developer Hub and no dice there. No idea where to go from here.


Level 3

Your quest is bricked only fix is to sideload or wait till they fix this atrocious system

Community Manager
Community Manager

Hey there, @ChoosingSet9267!


We see you got yourself in a bind, having to deal with some app issues like that. Let's see if we can't unbind this situation and get you back in VR. Moving forward we have some troubleshooting steps we'd like for you to try. Kindly attempt the following:


  • Sign out of the app
  • Uninstall the app and leave sitting for 5 minutes
  • Reinstall the app and leave sitting for a couple minutes
  • Sign back into the app and try to pair again
  • Clear Bluetooth cache/computer history of the app


As well, if that didn't prove any fruitful results, try the above steps but with the following:


  • Sign out of the headset
  • Hard reboot headset (hold power button down for 30-40 seconds)
  • Once headset is turned back on, sign back in


However, if you've tried the above and nothing came from those attempts, then let's have you submit a support ticket here: Over there they have a plethora of tools to further help and get you back in the action!