cancel
Showing results for 
Search instead for 
Did you mean: 

Usb C not connecting to quest link

CaptainKek42069
Honored Guest

Hello, i recently got my quest 3, i love it and am happy i decided to purchase it, however to date my only issue is that my computer or my quest will not recognize each other when connected with a USB C to USB C.

i have had success with the same Cable using a USB A adapter on one end and tried to use the cable that came with the quest aswell. The quest will charge off of both ports but will only connect to quest link off of the USB C to USB A. Both ports are running usb 3.0.

My computer is a Lenovo Legion Tower 7i Gen 8 (Intel) Gaming Desktop, i have a 4080 with a I7-13700KF, the usb ports i’m using are numbered 8&12 on the tech specs that i am sending a link to. It will only connect to quest link off of port 12 but still draws power (i think more) off port 8. I have tried to flip the cable as stated in the original post but no luck, please do inform me of any potential solutions

16 REPLIES 16

MetaQuestSupport
Community Manager
Community Manager

Hey @CaptainKek42069! Thanks for reaching our about this. We are attaching a link for you to follow here, you can also try these steps to be sure the link connection is secure:

 

  1. Open the Oculus app on your PC.
  2. Turn on your Quest 2 or Quest.
  3. Plug your USB 3 cable into a USB 3.0 port on your PC, and then plug the other end into your headset.
  4. A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
  5. When prompted to Enable Oculus Link, select Enable to begin remote rendering using Oculus Link.
  6. Ensure Air Link is disabled in Settings on the headset.

 

Let us know if this works for you! 


 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

No, this did not help or fix anything, perhaps because i have a quest 3 and you appear to have given a solution for the quest 1 & 2. As previously stated i have a quest 3. Furthermore this support was completely unhelpful as neither my PC nor my quest 3 provided a prompt requesting to access data.

Furthermore Quest link also does not detect the headset when connected to the computer’s USBC port. I am quickly coming to the conclusion that you don’t have a solution to this problem judging by the commonality of it and the fact that you sent me a support response for past gen headsets.

Of which literally nothing was applicable, ive already repaired the quest link software, ive flipped the connector, ive done anything from the other support stations. Nothing seems to work for anyone. So what is going on here?

Hey there @CaptainKek42069! We want to be able to get you going so that you can have the best experience possible!  We want to know if you are using our link cable or a 3rd party? We suggest that you use our link cable for the best results, and without the adapter. Here is a link for you to check out on purchasing our cable! We look forward to speaking with you! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Futher testinf has proven that it is the USBC connection being the cause, with my quest 3 not even connecting to quest link over the cable it shipped with, it will connect with a third party usbC that had a converter to usbA. Thus proving its an issue with the quest 3 connectivity

Thanks for your swift reply @CaptainKek42069! The cable that you are mentioning is the charging cable and not the link cable. Sorry for the miscommunication! The link we have provided is our link cable, which will give you the best experience! Let us know if you have any questions!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I used the charging cable as a secondary to test if there was an issue with detecting the quest over it, and it confirmed there was because it once again failed to detect the quest over the usb-c port, if i place an adaptor to usb-a both cables will connect as a link cable. This eliminates the chance that its either cable causing the issue. The USB-C port on the computer works to charge the Quest 3, however will not work as a link cable. As such i am left to wonder why you are suggesting i waste money on a product that is USB-C to USB-C only that is advertised for link cable purposes only, it clearly states its not for charging in plenty of other responses ive read. This is ludicrous i feel like i am talking to a brick wall and am receiving more advice from youtubers and redditors on meaningful solutions than i have here, it is extremely discouraging 

We can empathize with your frustrations, and we apologize for our lack of clarity. We are simply stating that the link cable would be the best option for PCVR. However, as we read your message, the understanding we gather is that you want a cable that charges and links the Quest 3 to your PC for PCVR and for charging. Is this correct? We also see you saying that you believe it is the connection port on the headset. Is this correct? We just want to make sure we fully understand so we can better assist you.

 

We eagerly await your response!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

In a perfect world that would be ideal where it would charge and play, however i have seen the various posts and warnings against that for battery health. I am using the fact that the Headset will charge over the usb-c port to confirm that the port and the headset are connected. However the quest link program does not detect the PC from the Quest 3 or vice versca . That being said if i place USB-A adaptor on the cord the connection works for quest link. I wish to utilize the port for Data transfer as it is the highest speed port on my PC & when i play Flight simulators like DCS & MFS i prefer the ability to sit for longer durations and utilize the maximum power of my machines with minimal compression.

 

So the main issue comes down to me wondering what causes there could be for quest link to not detect the quest 3 when connected with a usb-c cable, whereas if i place a usb-c to      usb-a adaptor on the cable and connect to a usb-a port with the same cable it will detect the quest 3?

my frustration comes from the fact that i am fairly certain it’s a software issue not a hardware issue, for the aforementioned reasons, I apologize if i came off as hostile. I just don’t see how it’s advisable to put over a hundred dollars onto a data only cable when we are seeing that we are having issues sending data with that cable format unless i’m using an adapter. So my question in finality is, The port is working, the quest’s port is working, what software related issues could be preventing the quest 3 from detecting the pc or the pc from detecting the quest over usb-c

CaptainKek42069
Honored Guest

Just to add i can send a video to a support agent explaining and showing the circumstances if that would help

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?