Showing results for 
Search instead for 
Did you mean: 

VR Videos not playing correctly

Honored Guest


I tried playing some VR videos using the Meta browser (had only used the headset for games thus far) and it worked great once. Since then, none of the VR videos play correctly.

Things I have noticed and done so far:

  • I believe the menu that shows up when the video starts to play in 2D looks different from the first time.
  • The video in 180 view looks huge, not to scale and does not react to moving my head around in the video. This worked correctly the first time I watched a VR video.
  • None of the other viewing options work - 360 is pretty much the same as the 180, and the top/bottom or left/right views are so distorted they hurt my eyes
  • I have restarted the device several times.
  • I have deleted all data including the cache in the browser.
  • I have deleted and re-downloaded the Quest app in my iPhone.

Has anyone else experienced this? Super perplexing as it worked perfectly but only once. Almost feels like there needs to be a setting switch that needs to be toggled or something. 

Thanks very much in advance.


Community Manager
Community Manager

Hi there, @soccer09sunny! We really appreciate you sharing your experience with the community, and we absolutely want to ensure you can enjoy watching your videos as intended. To catch us up to speed, we have a few questions listed for you below:


  • Which Meta Quest device are you using?
  • Have there been any changes to your Wi-Fi network?
  • Have you rebooted your router/modem?
  • Is this only happening within the Meta Quest Browser?
  • Does this only happen with specific videos or any that you attempt to play?
  • Have you attempted a hard reboot of the headset?
    • Hold the power button down for 30 seconds > Wait 30 seconds > If the headset doesn't automatically turn on, press the power button again until the headset turns back on. 


If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks for your reply. 

  • I'm using Quest 3.
  • No changes to wifi - happy to reboot router (hadn't tried that).
  • It's been only an issue with the Meta Quest Browser and has happened with all videos I've tried watching since the first one that worked fine.
  • Youtube VR seems to work ok. 
  • Tried hard reboot, didn't change anything.

Hey there, @soccer09sunny. Thank you for getting back to us with the answers to our questions. We would like to ask a few more questions to get a better understanding of your issue. Can you answer the following?

  1. What websites are you attempting to watch VR videos on?
  2. Have you tried a factory reset? If not, you can find the steps here.

We hope to hear from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello again, @soccer09sunny! We noticed that we haven't heard back from you yet. We want to ensure that you are fully taken care of, so if you still need help with this, please reach back out.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?