Showing results for 
Search instead for 
Did you mean: 

VR in iRacing, stutters randomly, vision is extremely distorted, occasional complete black

Honored Guest

I am attempting to use my Quest 3 to play iRacing, I have a 3070 and ryzen 7 5800x, my settings on iRacing are turned down to only having the car textures on High everything else is low / off. the resolution on my Oculus app is set at 0.9, the refresh rate at 70hz.

The issue is that after maybe 5 minutes into a race, the VR starts looking terrible, it gets all distorted and it looks like certain squares are not where they are supposed to be. Randomly it will begin to stutter and freeze. Additionally, sometimes the whole thing just shows a black screen. I am using the Quest 3 Link cable from Meta its brand new.


Honored Guest

I'm having the exact same issue. I have way beefier specs than that too and it's only on certain series and tracks.  Tried not using a cable and was still an issue.  Used my old rift headset and the issue went away.  I think it's the headset and iracing 


Same problem here. Good to know it's not my third party cable. When it happens, its out of nowhere and for seemingly no reason, game stutters, some areas on one lense become out of sync and pixelated, occasionally it will run at 1 frame every few seconds. My only solution is to close iRacing, disconnect the cable, plug it back in, turn on quest link and rejoin the lobby.

Definitely a Quest 3 issue. I do have an old HTC Vive, no problems there other than the obvious differences between the 2 headsets. Really hope it's something that gets fixed with an update, otherwise I'm probably gonna sell the headset and just get a better PCVR headset.

Just in case somebody actually looks into this, my PC specs are:


i9 12th gen processor

128 DDR5 RAM

B760-F motherboard


Hey there @santa_storm! Hey there! It seems like you're experiencing some display problems with your Quest 3 while playing iRacing. That's definitely not what we want to hear, but don't worry, we're here to help! Let's try solving this together, shall we? To start off, we suggest giving your headset a hard reboot and giving the game another shot. Here's a quick guide on how to do it. If you have any questions, feel free to ask us!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I already do that when it gets really bad. The problem is that it happens out of nowhere. I have noticed that, for example, if I try scratching my nose, the problem starts. Could it be the sensor that detects when you put the headset on your face that starts the issue? The screen doesn't turn off though. 

Any more serious help would be appreciated. If there are any tools that could give me data that's valuable for you, I'm more than happy to go through the trouble of getting it. The problem isn't exclusive of iRacing as far as I remember, any other wired PCVR game I play gives me the same problems, I have to use a WiFi 6e router to play PCVR games with Virtual Desktop to avoid this issue.

Thank you for clarifying that up with us @santa_storm! We want to Make sure your GPU drivers are up to date. Disable any VPNs or antivirus that could be interfering with the headset's connection. So we don't repeat any, what troubleshooting steps have you already tried? 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Like I said, I unplug the quest link cable, plug it back in and restart iRacing, if it's too bad I just restart the headset and/or my PC. Currently running the headset at 90Hz with a 4128x2208 resolution, but regardless of the refresh rate or the resolution, I still get this problem.

On the Oculus Debug Tool, I've turned off Asynchronous Spacewarp, but it somehow still kicks in. I had my Encode Bitrate set to 850, but I've lowered that to 700 atm. Problem is still there even if I had it at 500. Link Sharpening is disabled.

Forgot to add that I HAVE to run the headset using OpenXR, otherwise it wont launch iRacing. So, I have to select OpenXR on the Meta Quest app, then in iRacing I do launch the game using it's Oculus option. 

Thanks for sharing this information with us! Did you try uninstalling and reinstalling iRacing? We recommend giving it a shot and see if that resolves the issue for you. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there @santa_storm! Just wanted to make sure if you still need any assistance. Feel free to reach out if you have any queries!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

To be completely honest, you all keep giving me answers that are the equivalent of "well, have you tried unplugging it and plugging it back in?", so I'm just gonna sell the headset and get a Pimax Crystal. I know you just work here, but **bleep** bro.

I'm not even the original poster, so if you're asking to close this thread, don't.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?