cancel
Showing results for 
Search instead for 
Did you mean: 

Vader immortal issues

SurferRob1
Level 3

I posted yesterday about a problem I was having with the Vader immortal bundle I purchased. All three episodes required an update and of course I updated.  Since then, the game lags, the sound disappears, and the game starts glitching. I got an email saying to try and factory reset and reinstall all software to see if the issue resolves itself. Did all that and I get the same result. I replied to the help support email stating what I did but it came back as undeliverable because the support help email was invalid. I’m more than a little aggravated at this point so how does this get fixed or how do I get a refund? 

4 REPLIES 4

TheAntiSocializer
Meta Quest Support
Meta Quest Support

@SurferRob1 If the issue only seems to be happening with the Vader Immortal games. Your best bet would be to reach out to the developers since it could be something on their end.

 

Have you already given that a shot by chance? 

 

If not, feel free to hit them up to see if it's something they've been seeing with these links here:

 

 

If you're having the same issue with other games as well, please feel free to reach back out and I'd be happy to help take a closer look. 

Thank you! I’ll look into it! 

Nope, still the same issue. Reached out to them on their social media pages but got absolutely NO response. I’ll chalk it up to **bleep** software and deleting. Wasted $20 and got nothing but aggravation. Thank y’all for the help. 

@SurferRob1 No worries, I really hate that you're still having issues and have had no luck with the developers.

 

Feel free to shoot over a Private Message to our forum support team, and I'll talk to the right people so we can get this sorted out for you.

 

Let me know once it has been sent out! 🙂