Showing results for 
Search instead for 
Did you mean: 

Waltz of The Wizard wont open (new update broken?)

Honored Guest

I just installed the October 25th update for Waltz of the Wizard, excited to play with the new features and such, I attempted to open the game, and I can't get past the loading screen - the game just crashes and closes on its own. 

I tried restarting my headset, and it still wouldn't open. I tried reinstalling the game, and it still wouldn't open. None of my other games are having this issue, so I assume something with the update is just completely incompatible with my device? Perhaps it thinks my quest 2 can do the AR feature like the quest pro? Whatever it is, I'm unable to play an incredible game and I'd like to have this issue fixed so I can get back to casting spells.


Honored Guest

Hi and thank you for the kind words! 


Can you please check if you're on the latest firmware on your Quest 2? (Settings > System > Software Update)

Honored Guest

I'm having th same issue hopefully they can get this fixed soon.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?