Showing results for 
Search instead for 
Did you mean: 

What Wifi 6e routers currently works bug free with the Quest 3?

Expert Protege

Hi! Just wanted to post here to get a seperate thread going. As of today there is a major bug in communication between Quest 3 and certain types of Router models. 

So let's get a list started on Wifi 6e routers that actually work. What Router do you have experience with being stable at 2400 Mbps in dedicated 6e mode?

Remember to post Router name and model and screen grabs/video from the Quest 3 showing the speed. (Turn on experimental wifi settings to do so.)

This is by no account a list that is for everyone. So far I found that some of the more expensive models between 350-700$/€ have been reported to work. So meta still has a major bug to fix. But if you can afford it, this might be is a way around the problem… 


The bug explained:

There is a bug with negotiation rates with certain router models. Essentially AX and AXE models but more might also be affected. I have been investigating this bug since launch and finally both Meta and TP-Link have confirmed that the Quest3s negotiation protokolls with the routers is very unstable. This problem is totally unrelated to VD or AirPlay functionality, but it's here you'll notice the problem.

As of right now the Mbps can flux from approximately 1080 to 1900 on 6G and ocasinaly dip down below 800. Making it stutter and glitch in latency.

On 5G it will flux between 1080 and 420 Mbps making it essentially unusable in wireless PC streaming.

Both Meta and TP-Link are currently investigating the problem.


Meta has stated that the problem will be fixed with a firmware build in the near future.

If your experiencing this bug and want to follow its progress you can follow this seperate thread:



Why is it that there aren't more people, like youtube channel owners reporting similar issues? it must be universal throughout every one sold. The firmware must be the same, or get updated. The chipsets in the headset is exactly the same. 

Heroic Explorer

That is true, but if what TPLINK's engineers found is the primary cause, that the main problem is that the Quest3 wifi receiver is overly sensitive to interference, then the issues people experience will wildly fluctuate on a combination of three things:

1) Signal strength of router

2) Ability of router to deal with interference and dropped packets

3) Specific wifi environment of each user e.g. amount of interference


So, it may be that most people actually have no issue with Quest3 wifi, and people who are complaining are a small percentage who happen to live in an area that has a high level of wifi interference.  Hundreds of thousands have been sold, and the reports are in the hundreds at most.  I personally know two people other than myself who bought Quest3 and it worked 100% fine with their existing routers with no special settings at all, just using the defaults.  On the two routers I used it on (RT-AX86U, GT-AX11000 PRO) I've had no significant issues either, and I am about to try a third on 6ghz as an experiment to see if that is better or worse.


Ive just managed to have a reasonably good play again with HL-Alyx. I fiddled with some router settings on 5ghz and found the game dropped 5 frames to 85 and the 'game' setting in the VD monitor was about 12 or something. The only two orange ones showing. Then during play I got my usual controller lag/lose tracking episode (only effects HL-Alyx) and after it corrected itself, it went to 90 frames and the 'game' reading was normal too. That is very odd. It seems to be incredibly sensitive and border-line failure nearly all the time. I am keeping the router. It's a brilliant bit of kit and I just hope this gets fixed. Poor tfosseli seems to of been blocked or banned from reporting issues. Which I think is disgusting when it comes with customer support. Maybe they think he's the only one suffering from this issue. 

Heroic Explorer

yeh one thing I noticed with VD, if any other component of your PC gets lagged, then it can in turn lag the network, I assume as its waiting for the other part of your PC to rectify itself.  one game in particular i found that seems to be a PC killer is the Meta PCVR store version of Boneworks (havent tried SteamVR version).  Not all the time, but I've found certain areas in Boneworks that lag multiple of the subsystems of the PC measured by VD.  Read that its just super demanding in general due to its physics

Heroic Explorer

I have now acquired a GT-AXE16000 (on sale on Amazon now for $440) and it is in a similar setup as I had before:

Original setup was GT-AX11000 PRO + GT-AX6000 mesh - Quest exclusively on 5GHz-2

Now setup is GT-AXE16000 + GT-AX6000 mesh - Quest exclusively on 6GHz

RESULTS: Quest 3 had no difficulties locating and staying connected to the 6GHz band of the GT-AXE16000, connection remained stable throughout testing.  The link speed on v59 on 6GHz with the GT-AXE16000 was extremely similar to the GT-AX11000 PRO on 5ghz at 160mhz channel width, which is what I expected - between 2401mbps and 2161mbps.  Latency, was maybe 1 or 2ms better on the 6ghz band? Nothing to write home about that was noticeable in gameplay, though maybe the slightest bit more stable.  In terms of signal strength, a room over from the router and through a wall the 6ghz radio was about 15db worse than the 5ghz radio, so if you don't plan to play in the same room, 6ghz is a bad idea.

In summary, if you want a 6ghz router, I can confirm the Quest 3 works well with the GT-AXE16000.  However, if you are able to maintain a 160mhz channel width 5ghz band without interference, expect little to no improvement from the GT-AX6000 or GT-AX11000 PRO to the GT-AXE16000. This is what I expected theoretically, but have now confirmed it in testing.  The main improvement with the GT-AXE16000 is getting a wide open 6ghz band, if you need that - but I suspect a lot of people might.

In summary, I can confirm the GT-AX6000, GT-AX11000 PRO, and GT-AXE16000 all work incredibly well with the Quest 3, and the one to buy of these three depends on your home network circumstances/wifi interference.

I have now played 3 hours or so straight of Asgard's Wrath over virtual desktop, 200mbps AV1 10-bit, Godlike, 90hz.  Worked flawlessly on the 6ghz band of the GT-AXE16000.

Honored Guest

First of all, thanks to all of you for your insights, which ive been following since a few days as a fresh Quest 3 owner.

I returned my Fritzbox 7530AX, which supported up to 1200 mbps using 5 GHz. However it was all over the place and not consistent at all, bouncing sometimes even as low as 500 mbps while playing and causing stutters ingame.

In my search for a reasonable 6 GHz router, I came across the MSI Radix AXE6600. Result: The Quest now has a continuous, absolutely nailed down 2401 mbps connection via Virtual Desktop while playing Beat Saber, which did show the most problems with the Fritzbox. The Quest is over 3 meters away from the router and is the only connected device using the 6GHz band. No fluctuations, literally NONE.

Some comparisons and reviews have shown that the router could be a bit stronger in the 5GHz range, but that's a high level of complaining and I think you also have to factor the price into the formula.
I got the AXE6600 as part of the Black Friday offers in Germany for just under 170€. The normal price here is around double that.

If I've forgotten anything, please let me know.

Heroic Explorer

I figured the MSI Radix might do well since it's a Qualcomm chipset, I had mentioned it to another member to try via PM for that reason .  I actually wanted to try it myself but it doesn't support mesh.  How are you finding the range on it?

Note, if the Radix works that means the Synology RT6600AX also works since the former is a clone of the latter.


Can anyone else confirm that MSI Radix AXE6600 is working perfect in the 6Ghz band with Quest 3, without fluctuations, connection problems etc ?  


Since I recently grabbed myself the Asus ROG Rapture GT-AX6000 router, I've been doing a bit of trial and experimenting. My router is wall-mounted and my play-area is just a metre or two from the router. With a great suggestion from Ruined, I've discovered that many of the apps/background tasks on my Window 11 PC (AMD Ryzen 7700X, RTX3080, 32gb DDR5 6000mhz, Gigabyte X670 Gaming X AX motherboard) were interrupting the flow of things with Virtual Desktop.

Now I know the situation can be very different for folk, but after shutting down a few apps and disabling ExpressVPN, I've pretty much had success every time with great stats on the VD monitoring function. Perfect play with no crazy lag/latency (a little during loading though, but that seems normal). Frame rate consistent, 2401 Mbps. So a big thanks to Ruined for this suggestion. I'm sure the router itself has a lot to do with it too. But it might work for someone out there maybe. 

May not work for everyone, but it might be a good thing to try if you've ran out of idea's. A fresh reboot before shutting down apps can also help if you've been using the pc a while before-hand.


I ordered it. Then I will let you know how it is for me. But it will probably take a while because it wasn't in stock.