Showing results for 
Search instead for 
Did you mean: 

Whats wrong with my right controller trigger?

Honored Guest


This morning I noticed an issue where I cant seem to properly use trigger to click in beat saber, it works fine outside of beat saber. Picture above is me clicking trigger with both hands. The left hand index finger seems to be touching with the thumb however that was not the case with the right hand. Is there a way to fix or recalibrate this?


Honored Guest

This is happened to me too! Works everywhere else, but in beat saber the trigger on the right controller won’t click. 

Hey there! We know trigger issues aren't any fun, so we'd love to lend a hand. 


In order to gain a bit more insight, can you please answer the following:


  1. When was this first noticed?
  2. Does the issue strictly happen with Beat Saber, or other games also?
  3. Have you tried any troubleshooting already by chance? (Just to not repeat anything)

We look forward to your update!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey again! Just checking to see if you were still needing some help with your trigger issues. 


If so, don't hesitate to reach back out anytime! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Same here, other games affected too but Home Screen it works fine. Did anyone find a fix?

Hello. I am having the same issue with my right controller. In the Oculus dashboard and menus it works fine, points and clicks ok. But go into any game ie Beat Sabre, left points and clicks ok but right points ok but will not click on anything. I play Table Tennis a lot but cannot click on anything to play. Any thing I can do please, don’t really want to buy a new controller.

Thanks in advance👍

Hey there, @michael.birtwistle.7. Being able to use your controllers in games is pretty important and we would be happy to help you out however we can!

The recommended solutions will be different for each device, and we wanted to ask if you had a Meta Quest headset, or a Rift headset, and which version you had. However, we do have some general steps we would like you to try as well:

  • Remove the batteries from the controllers, wait 5-10 minutes before putting brand new ones back in.
  • Restart your headset:
    • For Meta Quest, power it off for 5-10 minutes before powering it back on.
    • For Rift, unplug the device from your computer and plug it back in after 5-10 minutes.
  • Ensure your controllers are clean by wiping them down with a dry microfiber cloth, and gently blowing them out with a can of compressed air for best results.
  • Remove unsupported third-party accessories that may affect button movement or controller detection, such as controller covers, attachments, etc.

Please let us know if you continue to have issues, as well as what device you have, and we will review what we can do to help you out further. We hope to hear back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi, thanks for the reply.

I have The Meta Quest 2. 
I have took battery out for 10 mins, unpaired and re paired again but still same.

It works fine in the menu, library, settings etc but go onto Beat Sabre for example and it stops working. Points ok but will not click on what’s pointed at?


Thank you for the quick reply @michael.birtwistle.7!
Regarding your Meta Quest 2, just to clarify, do you experience this issue in all applications or just Beat Saber? We recommend trying 2-3 different applications to confirm. We also recommend the following steps for Meta Quest 2:

  • Reset your guardian boundary from the headset settings
  • Test a different play space, in a different room
  • If possible, consider testing a different pair of controllers
  • Consider attempting a factory reset of the headset to ensure there are no software issues causing the problem.

We would like to leave the factory reset as the last suggestion and understand that not everyone will have the ability to test another pair of controllers. So feel free to reach out to us directly from our Profile Page and we would be happy to investigate this further to see how we can help you out.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi thanks for quick reply.

I have tried different rooms and changed boundary. It is the same on all other games. I play Table tennis but cannot click with right controller which is a problem as I am Right handed. I do have access to other controllers and will try tomorrow at my Grandaughters house👍. Beat Sabre is good because I can click with left controller but others games you cannot and hav3 to use the right only. Golf is the same. I will let you know how I go on with other controller👍


Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?