Showing results for 
Search instead for 
Did you mean: 

When I try to use pc vr with quest, I get the 3 dots loading screen.

Level 2

From what I've heard this is a pretty common issue but there's one thing that confuses me. If I run a vr game, I can control it using my vr and it works on the pc but on my headset I'm just stuck on the 3 dots.


I'm on quest 1 and my pc is vr ready. I use USB 2 which could be the issue but I don't know.

Any help?


Community Manager
Community Manager

Hey there! PCVR can be very immersing once you're in, so we'd love to help you out! 


In order to gain a bit of insight, could you please answer the following:


  1. When was this first noticed?
  2. Is this your first time using Link via cable?
  3. Is this an official Oculus cable, or a 3rd party cable?
  4. Do you have any 3.0 ports you could test out? 
  5. When you say your PC is VR ready, does it fully meet the Link requirements?
    • Could you list out your PC specs? (OS, RAM, GPU type and version, CPU)
  6. What all have you tried already? (So to not repeat any steps) 


As for your USB 2.0 question; it could very well be the fact you're using a 2.0. However, we don't want to fully come to that conclusion as of yet. 


We're looking forward to that update! 🙂 

Community Manager
Community Manager

Hey again. Just following up to see if you were still needing some help.


If so, you can reach back out anytime and we can jump right in!