Showing results for 
Search instead for 
Did you mean: 

White screen but does boot up. I tried factory reset but still does the same thing. Is it fried?

Honored Guest

Community Manager
Community Manager

Hey johnmackk! That's no good! Nobody likes being flashbanged as soon as they turn their headset on, and we wouldn't wish it upon our worst enemy.


To start, make sure your headset is fully charged. If the factory reset option didn't work, try holding down the power button for 60 seconds to see if the headset has any sort of response.


If you still encounter a white screen, we urge you to please reach out to our support channel and open up a ticket. We'll follow up with you as soon as we can!


When you reach out, be sure to include a detailed description of your issue, reference this post, label which troubleshooting you've tried already, and provide a picture if you can.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!