Showing results for 
Search instead for 
Did you mean: 

WiFi 6E not working on Quest Pro, even after RMA


Hello guys, I've talked with this topic last month on Reddit with this exact problem to hopefully get some answers, but to no luck. So I turn to the Meta forums.

It all started when I first upgraded my old family router to a 6E mesh system, and although someone told me mesh isn't a good idea, it still runs 6ghz anyways and the model that I bought was confirmed by two other members of the subreddit that it works with the Quest Pro.

I had three TP-Link Deco XE75 Pros set around my house, and attempted to connect my Quest Pro to it. No luck. I've tried restarting the headset, forgetting the 5ghz network and trying to manually add the 6ghz SSID (yes, I do have separately named SSIDs for the 2.4/5ghz and 6ghz bands), and even forcing my Quest Pro to ONLY connect to the main mesh point, but nothing still worked.

I then added to my mesh system with two TP-Link Deco BE95s, using one to now act as the main router (and also to take advantage of my family's higher data speeds, not just for the headset only) and did the same troubleshooting systems. To no avail.

I've tried factory resetting, tried on v55, v56 PTC, and now only recently two updates of v56 public, and still nothing. I went to Meta support to which they lead me through mostly the same steps of troubleshooting, but also they also had me try disabling the 5ghz band, leaving only the 2.4ghz and the 6ghz SSIDs. Nope, didn't work as it only recognised the 2.4ghz band.

With all the troubleshooting I've done and told them what I've done already in the past, they decided to RMA my headset. Last week I've received my new replacement and once again, I've done every ounce of troubleshooting that was done before on my old headset, and yet nada. Nothing works.

I've doublechecked my router settings, tried changing WiFi channels (unfortunately no manual setting for Deco routers, but it does like to switch channels quite frequently with the auto-interference feature), always making sure software is up to date, tried rebooting, and I'm still back to square one with my new headset.

What's going on here? Almost a full year since the release of this headset and yet somehow WiFi 6E still can't be supported from all 6ghz routers? Please, if anyone has some answers or solutions then I would be absolutely grateful for them. Otherwise I'm just completely stuck once again.


Community Manager
Community Manager

Hey there, @Kurrai6095! We'd want to thank you for following through on all of our troubleshooting suggestions. So, we'd want to step in and assist you in getting this fixed as soon as possible. We'd also like you to try connecting your headset to another internet connection. Also, if you could change the channel from your router to connect the headset, and if you could utilize channels 50-68 or 96-144, please let us know how it goes so we can determine if any extra steps are necessary.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Unfortunately that's the main problem with my routers, the Deco routers I have doesn't let me manually change the channels and only automatically switches between 69 and 85 whenever it detects interference. It might be something to bring up to TP-Link instead

Hmm, you also mention not being able to connect this headset or the one we replaced to your WiFi; please let us know whether you've tried using an alternative internet connection. so that we can decide the next steps in our troubleshooting steps.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I am having the same problem. I have a 1 month old Quest Pro, running the latest PTC software. I also have 12 Quest Pros of varying ages in a professional setting that we are using for a VR experience.

They will all connect to a Netgear Nighthawk RAXE500 just fine, but they will not see/connect to the following:

TP-Link deco of various model numbers
Ubiquiti U6
Ruckus R760

Having dug into it a bit with ADB, I've noticed that the headsets spend a lot of time scanning for new networks, especially if they do not have Internet access on the SSID they are connected to. We have had instances where Meta pushed updates that broke the VR experience with no warning so we've preferred to keep them off the Internet.

When the headsets scan, the underlying Android OS will filter some of the SSIDs out so not everything will appear as an option in the GUI to connect to. Interestingly, the Ruckus, TP-Link, and Ubiquiti SSIDs don't even show up in the 'dumpsys wifi' output via Android Debug Bridge. So it's not necessarily a Meta bug -- but more of an Android 12 issue.


There is in fact a 6E bug in Android 12, and some access point vendors have implemented variously named 'wifi6 control SSIDs as a workaround. Devices will filter these out from the user, but without them being advertised (correctly, or in a way the Android 12 device is expecting) it will treat all SSIDs from that BSSID (i.e. MAC address) as invalid.

My running theory is that the '6E control' SSIDs are implemented differently from vendor to vendor, and someone at Meta is unaware of this, and the Meta config/build/devops process is broken somewhere. If it does not see a particular control SSID to go along with it, it's probably considering it an unusable SSID and not even reporting that it exists. There's evidence for this in the fact that the base Android OS running the headset doesn't even see the SSID as I mentioned above, it's completely absent from the debug output in dumpsys wifi.

It is very frustrating, as this isn't a particularly complicated problem but the combination of lack of resources available at Meta, disinterest in the Quest Pro headset in the future product portfolio, general arrogance of the Meta team, and the fact that the source of it is likely an Android bug are all combining for this not getting fixed.

I haven't exactly connected it to a different WiFi connection, other than my phone hotspot which does work. There is a function to have a separate SSID for guests which I tried, but it only connects to the 2.4/5ghz band for that.

Oh wow, very interesting. Thanks so much for this response and your research into this issue, quite bizarre this entire situation. Quite a shame because I really do like this headset especially as a glasses wearer, it's perfect for me. But it's just the 6E issue which is kind of tainting it for me.

Yeah, and you can tell by the Meta support response of asking you to try an "alternative internet connection" that their understanding of the different components involved here is extremely lacking. I'll bet there is someone on the product team who knows what is going on, but getting to that person has proven nearly impossible. I am going to try creating my own 6e control SSID in the Ruckus, as it supports multiple SSIDs on the same radio/frequency. Can't do that in a TP-Link though as far as I know.

They are barking up the wrong tree on the channel selection as well - that has nothing to do with it. I've put up SSIDs on all the PSC channels at 20 and 80mhz widths -- 5, 21, 37, 53, 69, 85, 101, 117, 133, 149, 165, 181, 197, 213, 229 -- and gotten nowhere.

What probably happened somewhere is someone turned on a 5ghz freq with the same name as the 6ghz SSID and the user and/or Meta support misinterpreted that as working correctly. No matter what you do with these APs that the Quest Pro "doesn't like", the SSIDs they present on 6ghz will not appear.

You can download the ADB (Android debug bridge) tools, put the headset in developer mode, run adb shell and poke around as I have. The command you want is 'dumpsys wifi', which will dump out basically all logging the headset has for WiFi since the last boot. You'll see the scans, SSID scoring, etc. The 6E networks are like they don't exist.

Honored Guest

I had the same problem with the router you have that solved it for me and removed the dual band (6Ghz only). This is because when it has multiple bands (6/5/2Ghz) it cannot connect. I've tested it on many 6e routers and this is the only solution I've found for the moment. It can be done from the application. I hope it can help you 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?