cancel
Showing results for 
Search instead for 
Did you mean: 

WiFi Drops Out Regularly On Quest 3

Talberto
Honored Guest

Hello! I apologise if this has already been discussed a lot in other posts but any I could find almost entirely ended with someone going to chat with Meta support privately off-forum.

I have had a Quest 3 for only about 4 days and I absolutely love it aside from some small issues. The biggest one for me though, is that I frequently lose WiFi on it, no matter what I'm doing. I'd say it typically happens at least once every 5 minutes, I get a notification that says 'WiFi connection lost, view settings to troubleshoot'. I am a few rooms away from my router and modem, but I don't tend to have issues with other devices I own when it comes to this sort of thing, and my Quest 1 never really had it either. Is this a software issue or something I can address myself, or is my unit faulty? Thank you in advance for the help!

RTX 3080, Ryzen 7 5800X, 32GB RAM
1 ACCEPTED SOLUTION

Accepted Solutions

TomCgcmfc
MVP
MVP

I'd probably try seeing if this happens if you use your Q3 in the same room as your router/modem first.  If it works there ok it probably means that you are either trying to play though too many walls and/or you have a lot of other 5Ghz devices connected a the same time.

I've found that the Q3 works much better if your router is a wifi6 (AX) than a wifi5 (AC) router.  I was getting a lot of Q3 wifi disconnects after v64 and ended up replacing my +5yo wifi5 AC router with a newer wifi6 AX router.  Since doing this a few weeks ago I've never had a single disconnect. 

This is a user forum so I'm sorry I cannot solve your problem.  Maybe try a little google troubleshooting for tips.

https://www.google.com/search?q=meta+quest+3+wifi+disconnecting+troubleshooting&sca_esv=83f986b0ebb1...

If you contact meta support they may be able to give you a free app to checkout your home wifi connection and see if they can recommend ways to improve it.  Good luck mate and cheers.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

View solution in original post

4 REPLIES 4

TomCgcmfc
MVP
MVP

I'd probably try seeing if this happens if you use your Q3 in the same room as your router/modem first.  If it works there ok it probably means that you are either trying to play though too many walls and/or you have a lot of other 5Ghz devices connected a the same time.

I've found that the Q3 works much better if your router is a wifi6 (AX) than a wifi5 (AC) router.  I was getting a lot of Q3 wifi disconnects after v64 and ended up replacing my +5yo wifi5 AC router with a newer wifi6 AX router.  Since doing this a few weeks ago I've never had a single disconnect. 

This is a user forum so I'm sorry I cannot solve your problem.  Maybe try a little google troubleshooting for tips.

https://www.google.com/search?q=meta+quest+3+wifi+disconnecting+troubleshooting&sca_esv=83f986b0ebb1...

If you contact meta support they may be able to give you a free app to checkout your home wifi connection and see if they can recommend ways to improve it.  Good luck mate and cheers.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

MetaQuestSupport
Community Manager
Community Manager

Hey there, @Talberto! As @TomCgcmfc let you know, the most common cause for what you are seeing, especially if you are on a 5ghz band, would be too much interference from walls/objects between the headset and router. Head into the room your router is in and test the connection in there with the headset in direct line of sight of your router. If you don't see the same issue, that would narrow the issue down to interference, and you would need to upgrade or move your router to mitigate the issue. If you are seeing the same disconnects right next to your router, please try the following:

 

  1. Reboot the headset.
  2. Remove any unsupported third-party accessories that may affect communication (such as headset covers, etc.)
  3. Try connecting to a different network.
  4. Make sure your files are backed up to the cloud, then perform a factory reset.

Hopefully those steps get things working more smoothly for you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

TomCgcmfc
MVP
MVP

@Talberto  Also, please make sure you do not have any uneccessary usb devices as this can overload your usb bandwidth.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

Hey hey, @Talberto, we wanted to check in to see whether you still needed assistance. We'd love to help you get to the bottom of this! 

 

We also appreciate you @TomCgcmfc for sharing those suggestions to try to help our community member! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?