Showing results for 
Search instead for 
Did you mean: 

WiFi connection problems

Honored Guest

I cant connect to my wifi network with Oculus 2. Network is visible and I'm providign correct password. Other devices are connected to it witout problems.

When I try to connect with Oculus, it says "connecting", and then "disconnected". No error message.


Community Manager
Community Manager

Hey there, @user_504183305365473! We see that you are having trouble connecting your device to your Wi-Fi. We know how having to deal with this can be an inconvenience for your VR experience, and we're happy to look into this with you!


  • Have you tried removing some devices from your current Wi-Fi network or using a different network?
  • Have you tried rebooting your headset and Wi-Fi?
  • Were you able to connect to your Wi-Fi in the past?
  • Are you using dual-band routers?


Please provide as much information as you can about what you are experiencing and what troubleshooting you have tried. Once we have more information, we will be able to better assist you with this issue!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

1) There is no capacity problem on my home router. I'm able to use my phones thethered network, but I need to connect to my home router to access resources on my home network.

2) Yes, I did reboot both.

3) Yes. I havent used my headset for about a year, now when I try to use it I will not connect.

4) Yes, it is dualband.

Thanks for getting back to us, @user_504183305365473. We'd recommend trying out a factory reset next, before doing this you'll want to make sure that your Cloud Backup setting is turned on. It should be active by default, double checking is always a good idea though. Below are the steps for performing a factory reset: 


From the Headset:


  • Power off the headset.
  • Press and hold volume down & Power.
  • This will boot into the USB Update Mode menu.
  • Press volume button to move selection, press power button to make the selection.
  • Navigate to Factory Reset and press the Power button.
  • The device should now begin the Factory Reset process.

Let us know how it turns out, we'll be looking forward to hearing from you! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I solved the problem

Turns out my router was slightly misconfigured, and strangely only Oculus headset had a problem with that. With fixed configuration no Oculus happilly connects to my home network

Thank You for your time.

Hey again, @user_504183305365473! We are glad to hear you are back up and running! We hope you enjoy the many wonders of VR!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Uh, I tried everything but the factory reset but 20 minutes ago my wifi was working, then i tried to connect an eero and everything messed up, app wont work and everything

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?