Showing results for 
Search instead for 
Did you mean: 

Wifi packet loss/latency spikes during movement since V57 (Quest 2 and Quest 3)

Expert Protege

As requested by @TheAntiSocializer, I extracted my bug report from ( into a separate thread to keep things organized.


Problem Description: As soon as you start to move around, the Quest 2 and Quest 3 devices since OS version V57 suffer from Wifi packet loss and latency spikes. It makes local networked games like ours unplayable. It works flawlessly with Quest 2 devices on V56, though. Here is a video demonstrating the issue (the video was recorded on older OS versions but symptoms are exactly the same on the latest OS versions): 

  1. What's the full version number of your headset? (62.0.0.####### or likewise)
    • Quest 3: (has packet loss)
    • Quest 2: (also has the same packet loss)
    • Quest 2: V57. has the same packet loss)
      All our other Quest 2 devices (22 devices) show not a single packet lost through the entire test:
      Quest 2: V56.
  2. What's the full version number of your PC app? (62.0.0.####### or likewise)
    • We are not doing PC streaming so we are not using the Oculus PC app. We are running a local networked game.
  3. Is your PC app on PTC?
    • NO / not applicable
  4. Are you enrolled in Quest PTC?
    • NO
  5. Any potential workarounds?
    • NO
  6. Which headset is everyone using? Is this only happening with the Quest 3 currently, or is anyone experiencing the same thing on their Quest 2?
    • Happens since OS V57 on both Quest 2 and Quest 3. Happens on none of our V56 Quest 2 devices (22 devices).
  7. Which router are you using? (Brand & Model)
    • We tried TP-Link Archer C7, Netgear Nighthawk RAXE500, P-Link Archer AX55(eu), ASUS RT-AXE7800, ASUS ROG RAPTURE GT-AXE1600 
      All routers are EU versions!
  8. What protocol is your router?
    • When comparing Quest 2 and Quest 3, I'm using WLAN 6 5GHz (according to the TP-Link router, this is "802.11a/m/ac/ax mixed" mode).
    • I also tried Wifi 6e (Quest 3 only) but packet loss was worse tried different channels etc. nothing helped.
  9. What bitrate is your Air Link currently set to?
    • Not using Air Link
  10. What are your system specifications? Do they meet the Meta Quest Link requirements?
    • Not relevant in our case, as PC is just the game server. Same PC is used to test with all Quest 2 / 3 devices (where all V56 work flawlessly and all V57 and up have great packet loss during movement).

Update: 2024-03-19
The problem seems to be caused by the positional tracking as it immediately disappears when position tracking is disabled via "settings / headset tracking" as demonstrated in this video:

Btw. if you have any new OS versions I should test or need any further information, I would be happy to help. We are in a pretty unique position when it comes to testing capabilities regarding this issue as we have lots of space which is critical as movement seems to mainly introduce this problem; have Quest 2 V56 devices that we use as a baseline to directly compare against; have a few different Wifi routers and can actually measure packet loss in software so we don't have to rely on subjective measures.

Thank you very much.



@VirtualOmnipresence could you try and see whether switching your router to 802.11a/m/ac only on 5G, ie switching off ax mode/wifi 6(e) helps? Obviously not a solution but should be helpful for Meta to pinpoint the issue.

Expert Protege

Same issue here, almost identical specs, builds and OS with Virtual Omnipresence!


@TheAntiSocializer just one further thought here as I don't see this in your fact finding list above - where I've read others mention this issue on reddit, discord and elsewhere, notably a lot of them were outside the US and esp. in the EU where wifi regs are different (and therefore i expect the q3 wifi implementation).

Eng team might need to test this on a EU (/non US) HMD & router to be able to reproduce.

I just tried switching to  802.11a/m/ac on 5GHz. That did not change anything for me. Packet loss and latency spikes are the same as they used to be.

Thank you for letting me know, I've already passed along that this is mainly pertaining to EU/Non-US areas. 


@Babinok thank you for the updated video tests. The second one doesn't really need to be posted in this thread as it's a test for PCVR, so it'd be best to not get the two mixed together (PCVR and Native). Regardless, I will be passing them both to the team as well.


Let's also be sure not to cross-post any messages as that does go against the Community Rules. Since our engineers want us to split PCVR and Native, cross-posts may confuse our relayed information. I am able to see and receive notifications for both threads as well, so I am able to see any information posted in both.

Sometimes it's okay to be a little Bing Chilling

@TheAntiSocializer is there really no way to downgrade the OS of existing headsets to V56? No undocumented developer only option or anything you could share?
One of our V56 Quests died yesterday and we are slowly running out of Quest devices that are not affected by the Wifi problems (i.e. those which are still on V56). Usually I would just replace the defective Quest by buying a new one but all new Quests we would purchase would automatically come with OS V62 and would thus have the Wifi bug "pre-installed" and are therefore not usable for us...
Furthermore, downgrading the OS would allow other people here on the forum that experience this Wifi problem to check if downgrading to V56 does indeed solve the issue for them as well. That would mean your developers could easily check what changes where made from V56 to V57 and thus narrow down the issue quite fast/easily (or simply fix it by reverting that change).


This problem is not only EU/Non US.  I am in the US, suffering with the same issues.

Hey @VirtualOmnipresence. The only way that I've seen people be able to roll back would be through SideQuest, but I'm not able to recommend that because if done wrong it could hurt more than it helps.

The only thing I'm really able to suggest right now is asking for a way in the Ideas Board since it'll be where the engineers can see it, and potentially make it a thing later on.

Sometimes it's okay to be a little Bing Chilling

Expert Protege

Hi @TheAntiSocializer ,
I signed up for PTC in order to test the V63. version. I wanted to let you know that the problem is still present.

Has the development team been able to reproduce this problem? Have they shared any estimate on when this problem is going to be fixed?

Btw. I checked SideQuest but it does not offer a solution to downgrading the OS version of the headset. As far as I can tell, there does not seem to be any way to downgrade the Meta OS.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?