cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi packet loss/latency spikes during movement since V57 (Quest 2 and Quest 3)

VirtualOmnipresence
Expert Protege

As requested by @TheAntiSocializer, I extracted my bug report from (https://communityforums.atmeta.com/t5/Get-Help/Not-Resolved-Known-Issue-Quest-3-Airlink-micro-lags-a...) into a separate thread to keep things organized.

-------------------------------

Problem Description: As soon as you start to move around, the Quest 2 and Quest 3 devices since OS version V57 suffer from Wifi packet loss and latency spikes. It makes local networked games like ours unplayable. It works flawlessly with Quest 2 devices on V56, though. Here is a video demonstrating the issue (the video was recorded on older OS versions but symptoms are exactly the same on the latest OS versions): https://youtu.be/XIsMOeJHwiU 

  1. What's the full version number of your headset? (62.0.0.####### or likewise)
    • Quest 3: 62.0.0.257.341.566161015 (has packet loss)
    • Quest 2: 62.0.0.257.341.566161015 (also has the same packet loss)
    • Quest 2: V57.0.0.236.669.513665197(also has the same packet loss)
      All our other Quest 2 devices (22 devices) show not a single packet lost through the entire test:
      Quest 2: V56.0.0.171.656.505989878
  2. What's the full version number of your PC app? (62.0.0.####### or likewise)
    • We are not doing PC streaming so we are not using the Oculus PC app. We are running a local networked game.
  3. Is your PC app on PTC?
    • NO / not applicable
  4. Are you enrolled in Quest PTC?
    • NO
  5. Any potential workarounds?
    • NO
  6. Which headset is everyone using? Is this only happening with the Quest 3 currently, or is anyone experiencing the same thing on their Quest 2?
    • Happens since OS V57 on both Quest 2 and Quest 3. Happens on none of our V56 Quest 2 devices (22 devices).
  7. Which router are you using? (Brand & Model)
    • We tried TP-Link Archer C7, Netgear Nighthawk RAXE500, P-Link Archer AX55(eu), ASUS RT-AXE7800, ASUS ROG RAPTURE GT-AXE1600 
      All routers are EU versions!
  8. What protocol is your router?
    • When comparing Quest 2 and Quest 3, I'm using WLAN 6 5GHz (according to the TP-Link router, this is "802.11a/m/ac/ax mixed" mode).
    • I also tried Wifi 6e (Quest 3 only) but packet loss was worse tried different channels etc. nothing helped.
  9. What bitrate is your Air Link currently set to?
    • Not using Air Link
  10. What are your system specifications? Do they meet the Meta Quest Link requirements?
    • Not relevant in our case, as PC is just the game server. Same PC is used to test with all Quest 2 / 3 devices (where all V56 work flawlessly and all V57 and up have great packet loss during movement).

--------------------------
Update: 2024-03-19
The problem seems to be caused by the positional tracking as it immediately disappears when position tracking is disabled via "settings / headset tracking" as demonstrated in this video:


-------------------------
Btw. if you have any new OS versions I should test or need any further information, I would be happy to help. We are in a pretty unique position when it comes to testing capabilities regarding this issue as we have lots of space which is critical as movement seems to mainly introduce this problem; have Quest 2 V56 devices that we use as a baseline to directly compare against; have a few different Wifi routers and can actually measure packet loss in software so we don't have to rely on subjective measures.

Thank you very much.

42 REPLIES 42

TheAntiSocializer
Meta Quest Support
Meta Quest Support

Thank you for getting this over so quickly! 

One thing I did seem to forget for your specific issue would be the Meta Quest mobile app version number. This can be found by clicking Menu then scrolling all the way to the bottom. 

As for everything else provided, I passed it along and I'll return with any updates/information or questions they may have for me. 

Sometimes it's okay to be a little Bing Chilling

Sure thing, the mobile app version number is: 255.0.0.12.109

Thank you very much for forwarding my report 🙂

The information from the participants in the previous topic does not interest you? Has your team acknowledged that there is a problem? Any preliminary guesses why the problem does not appear on all headsets with firmware 62?

Babinok
Expert Protege

Have you tried firmware 63 from the Quest PTC? 

I'm a little confused on what this is referring to, our team has been made aware of the other thread that's related specifically to an Air Link issue and they're investigating. However, there haven't been any updates provided that I can share with the thread. The user here is having an issue natively on the headset which is using different software than the PC app so I asked them to create this thread so that we may have a post for each relative issue.

Sometimes it's okay to be a little Bing Chilling

No, I'm currently not participating PTC.

"Any preliminary guesses why the problem does not appear on all headsets with firmware 62?"
If I could guess, it probably does happen on all headsets. But if you are sitting like 1m away from the router and not moving too much, you probably won't notice it.

This problem is not only related to the airlink software, but in general to any wireless packet transmission to quest 3 (Virtual Desktop, Steam Link, iperf3). All the tests and videos that I posted in the old topic indicate this. Therefore, the problem should be considered as a whole.

It'd be great to have it altogether in one place. With that being said, since PCVR (Rift) and native Quest use different software it makes it easier for the engineering team to have them in their own respective threads. This way they can see the information for each one without it getting drowned out by the other.

Sometimes it's okay to be a little Bing Chilling

Hey AntiSocializer, thanks so much for pushing this!

Just cross-posting from other thread for ease:

Just to clarify here - the issue from the other thread is not Airlink specific. I had just chosen to use the Airlink performance graphs to illustrate the issue. The issue is also present on Virtual Desktop and I expect any other application relying on a low latency wifi data stream.

Suspect trying to fix this via looking into Airlink will be a red herring for your eng team and my bad for not choosing a better subject line on the other thread.

For the purposes of this thread: I'm having the same issue as described above

- Issue observable in Airlink, Virtual Desktop, OpenSpeedTest (but easiest to pinpoint with AL perf graph for network latency). Presents in stutter, frame drops, and/or transmission speed drops when moving head (depending on application)

- Present on Quest 3 EU, NOT on Quest Pro EU (otherwise identical setup)

- Present on tp link axe75 (EU) and asus rt-axe7800 (EU)

- v62 non PTC but pretty sure it was already present previously

- issue present in 802.11ax mode on 5ghz and 6ghz (ie WiFi 6 and 6e); issue not/much less present in 802.11ac mode on 5ghz (160mhz in all cases)

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?