Showing results for 
Search instead for 
Did you mean: 

Wireless PCVR Image is Awash with Colors and Artifacting


Solution: Disabling the auto overclocking function set at the bios level resolved my issues. 

Problem:  The video below depicts what I experience when streaming PCVR while using the H.264+ codec. For the benefit of search engines, I will verbally describe it as a blurry, pixelated mess or blob of color and repeating patterns that sort of smears across the screen. It's a graphical glitch that can also resemble severe image compression of the type made famous by early-internet JPEGs.



This happens on Virtual Desktop and Steam Link, but only when using the H.265+ codec. The bitrate matters, but only insofar as how long I have to wait for things to get messed up. 


Router: TP-Link Archer AXE5400. Connected to PC with Cat 5 or 6 cable. This router is dedicated to the Quest 3. Bandwidth is not an issue, as demonstrated by the video above, which shows a steady 2401 mbps at all relevant times.



  • Ryzen 7 5700x
  • RTX 4800
  • 16GB Ram
  • Windows 10 Pro
  • Quest 3

As shown in the video above, my GPU and CPU are neither taxed nor hot while this issue occurs, and RAM is plentiful.


Things I have tried:

  • Reinstalling windows and all software. 
  • Reinstalling Oculus specifically, via repair method.
  • ALL drivers are up do date, from the bio, GPU, CPU, M2 drive, Oculus software, and headset. 
  • Reboot the headset using the power button + volume down button method. 
  • Changing to a different M2 drive with terabytes of free space.

Accepted Solutions


The solution was to disable the auto overclock feature in the bios. 

View solution in original post


Meta Quest Support
Meta Quest Support
Don't worry be happy.

Thanks, I dismissed that thread after seeing it earlier because I am not having rainbow artifacts and pixel glitches as described in the OP, but it seems others have reported a greater range of symptoms, some of which sound potentially similar to mine. Unfortunately, there is no solution posted in that thread other than returning the Quest 3 because Meta refuses to allow users to roll back drivers and seems otherwise incapable of resolving this long-standing issue. That is very disappointing and quite unacceptable. 

I will test to see if my issues have the same root cause by seeing if they persist when the headset is recording, then I will report my findings. 


Expert Protege

I remember seeing that the nVidia 4xxx series was not supported yet.

Has it been ever working?

They only JUST added 4000 series support.

Yes, the head set worked fine when I first began using it. Specifically, I never experienced any visual issues from December through early March, other than inconsistent compression efficiency that is game-dependent, i.e. FO4 looks like a compressed JPEG even at 500 mbps, but most other games look acceptable even at 200 mbps.  Admittedly, the diversity of games I tried in those three months isn't grand, and FO4 has vegetation, which is to compression algorithms what cheap well done steak is to my jaw muscles. 

You're welcome! 🙂 Thank you for informing me that the thread didn't specifically tackle your issue. Please keep me updated on any findings or reports while you try out different solutions.

Don't worry be happy.

As an update, I conclude I am not having a similar issue as those described in that thread. I have confirmed this by relieving the headset CPU of load by disabling super resolution, selecting 72 fps, and disabling ASW. Conversely, I also tried recording video and overclocking, via the option in Virtual Desktop. Nothing had any effect whatsoever. 


In addition, I have replaced the image with a video that depicts the issue. 


Finally, I have narrowed some of the parameters which corrects some findings I had earlier. Specifically, I can now say this only occurs when using the H.264+ codec. The effect of lower bitrates has also become more clear. Specifically, lower bitrates only delay the onset of the problem, and only by tens of seconds.  


Seems like it must be an encoding or decoding issue.


The solution was to disable the auto overclock feature in the bios. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?