Showing results for 
Search instead for 
Did you mean: 

Your computer doesn't meet the updated minimum specifications...

Level 2

...which can lead to a poor experience in VR.


I'm so confused as to why I'm seeing this message. Is my PC so underpowered that I can't enjoy Air Link? I thought I got a decent laptop, but seems I was wrong.


I'm a massive noob, so please forgive me if my knowledge of specs and Oculus is limited. If you have any questions, I'll try my best the answer. I just need someone's help understand where my pc is lacking.

Processor Intel(R) Core(TM) i7-10870H CPU @ 2.20GHz 2.21 GHz

Nvidia Geforce RTX 3070 GPU 8G
Installed RAM 32.0 GB (31.9 GB usable)
System type 64-bit operating system, x64-based processor


Level 13

most likely its picking up on the igpu.


go into device manager and disable the igpu (intel hd graphics), then go into nvida control panel to force the use of rtx 3070 for oculus.

Just did as you said.


Still getting the same message

Community Manager
Community Manager

Hi @iMikez The Nvidia Geforce RTX 3070 GPU is not yet whitelisted for AIr Link, however you should be able to try Air Link and see if it works. If you need any further assist please create a support ticket with us here, Thanks!

Level 2

Same problem here, and sadly Air Link does not solve it.

Intel Core i7-1870H 2.2 GHz plus NVIDIA RTX 3070 laptop.  It's a powerhouse, but "does not meet minimum specifications".

Air link works, but with the same issues as the official link cable, i.e., hiccups, even when the GPU is 30-40% utilized and the CPU 60-70% utilized, or less.
I tried overclocking both the CPU via BIOS (up to over 4 GHz) and the GPU via MSI Afterburner (also above 2 GHz).  Nada, zero improvement, it didn't touch the bottleneck.
I made sure via NVIDIA Control Panel that the relevant processes (ovr processes, oculus client, etc.) use the NVIDIA card. No improvement.
I also tried giving realtime priority to the processes via TaskManager.  No improvement.

Only thing I couldn't do is tweaking my DDR4 RAM parameters (it runs at 1600 MHz frequency): I tried changing the multiplier (default is 12 x 133 MHz, I tried 13) and/or lowering refresh intervals & C, but I get instability, so I can't say whether that would have any benefit.

In summary, it just seems that there is some sort of driver issue that requires the kind help of the OCULUS Support Team / Driver gurus.  I suspect it has more to do with memory bandwidth bottlenecks than processing power bottlenecks, but I couldn't properly pin down what it is.  

Does anybody have more info about how to solve this (or help the Oculus support team solve this)?

From my 'internet research', I believe that the 'Oculus software team' need to write an updated .json to include RTX cards in the 'Whitelist'.

I 'upgraded' from a GTX 1660 (this was fine, no problems) to a RTX 3070, which the Oculus app now reports as, "...does not meet minimum VR requirements"...really??? (this displays all over the Q2 which you cannot remove and is in the way!)

I have been on CS Chat (twice) help.  Posted in these 'Oculus Help' Forums and still have not received a reply/response.

Like RTX cards have been out since last September and still no updated PC app to include them...just frustrated and annoyed!! 😖

Level 4

Try bêta chanel, in oculus app for Windows, that disable the message for me 

Oculus quest 2 64GB
câble link newzerol 5meters/16fts USB C to C, 2.5 gbits/s average mesured, plugged in thunderbolt 4.0 port
Laptop Alienware X17 3080 rtx 150w, I7 11800H, 32bgo ram xmp, 4k screen


Sorry, could you explain, because if you mean Settings - Beta, there is nothing obvious there that allows you to disable the nag screen. 🤔

I tried to resolve another problem, my oculus home from link has never load since two week i am owner of the quest 2.


A oculus agent tried to Help me by chat and recommended me to suscribe to bêta chanel from oculus app for Windows.


That make disappear the message into home automaticaly for me, but still got this banner in oculus app for Windows.


My oculus home from link still don't load after many solution tried 🤬


Sorry my word, i am french. 

Oculus quest 2 64GB
câble link newzerol 5meters/16fts USB C to C, 2.5 gbits/s average mesured, plugged in thunderbolt 4.0 port
Laptop Alienware X17 3080 rtx 150w, I7 11800H, 32bgo ram xmp, 4k screen

Hi Farah-Eliott,

I understand what you mean now...It is Settings - Beta and turn on the 'Public Test Channel'.  Many thanks for advice, however, I do not really want to be a 'guinea pig' for unfinished software, I will wait (may be a looonngg wait!!) until Oculus sort it out 😀


Do not apologise for 'being French', your english is probably better than my french! 😁