Showing results for 
Search instead for 
Did you mean: 

beat saber not launching any more today after an update

Level 3



I've played beat saber for some months. Yesterday it worked fine. Today the game won't launch. When I open it, it goes back to the home page. Demo version works ok. I reinstalled the game, I did a soft reset. Everything works ok, all games open ok. Just beat saber does not want to launch.

Any ideas please.


OK.  I was a little impatient.  It worked.  Thank you!

Not applicable

This might work, go to settings off the hime

screen. Scroll down and select About. The top option is software related. I think the option is update and restart. Maybe give that a try. Hope this helps.

How do you update your oculus software?

Level 2

I also had this problem. Thought I had everything updated and Beat Saber still would load. As I was giving up I decided to report as a Bug under Settings. When I did that I got another option to update the hardware. I accepted and after that Beat Saber worked. 

Mine says, you need to plug in the device for the update. Plug in to what???