cancel
Showing results for 
Search instead for 
Did you mean: 

can't set oculus as active openxr runtime

jeevil
Level 2

jeevil_0-1635902283795.png

i have a quest 2 and use it on link but it wont work at all because when i click the button here it just does nothing

 

in the quest when i click enable link it loads for a few seconds and just reloads the home area (nothing happens)

please help my quest 2 is unusable for pcvr like this and it seems like such a simple thing

48 REPLIES 48

I've got a brand new Quest 2, and it won't connect to the PC. I've tried all the above fixes, including trying to make the registry change. But I can't because the registry key doesn't even exist! The only thing under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Khronos is Vulkan, there's no entry for OpenXR. I'm stuck. Help!

I'm also having the same issue. There's no entry for OpenXR. Help!

Hey there! Being able to connect to your PC definitely opens up a lot of doors for VR gaming, so we'd love to help out with getting you connected. Please reach out to us in a support ticket with your log files attached, so that we can take a look at what might be causing the no entry error.

I had the same problem, just run regedit as admin that fixes it

Wagi94
Level 2

I made a Tool which automatically detects installed OpenXR Runtimes, allows you to switch between them & add custom ones. This will do the needed Registry Edits for you: WaGi-Coding/OpenXR-Runtime-Switcher

Hope it helps someone 🙂

Greetings from Vienna

antgiant
Level 2

This is a bug in the Oculus software.

 

However, there are several things going on at once. First of all the registry key that needs to be updated requires Admin rights to update. As mentioned elsewhere using a Registry editor (as Admin) visit 

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1

and update 

ActiveRuntime

to

C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json

 

However, the Oculus software will then show "None" as the active software. This is because it incorrectly looks at the old location for this data in the registry

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Khronos\OpenXR\1

so if you want the Oculus software to correctly show it has been set as well then you need to duplicate the ActiveRuntime registry setting in that old and incorrect location as well. At least until the software gets updated and points to the correct location again.

 

Hope that helps.

mo.chavr
Level 2

mochavr_0-1662644014576.png

It worked for me. Thanks @antgiant 

 

So go inside the below directory in Registry (if you do not have it, create it):

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Khronos\OpenXR\1

 

Then create a string value like below:

mochavr_0-1662644324612.png

Quit and open the Oculus app again. It will not show you the blue bar message anymore.

Then yall are a bunch of **bleep**ing idiots that have no business running this joint.

I am having the same issue and I think I understand why, but don't know of a solution other than deleting my account, factory resetting my Quest 2 and starting over. I have an account that was originally associated with the original Oculus Rift, from back before facebook owned it, and then after. Once facebook bought Oculus, it forced me to associate my Oculus account with my facebook page. Now the Rift and Quest 2 that I use are acually owned by my school for educational purposes, so they are not mine, but I had to associate my account with my personal email since my school does not allow us to have access to facebook. Now that a facebook account is no longer needed, I set up an account with my school email and migrated my original profile into that one. Now if I try to "Activate" the Quest 2 using my school email acount, it insists that since all purchases and apps are associated with my personal email, it is not able to Activate the Quest 2 and a factory reset must take place. Since the account with my personal email required me to connect through facebook, I am not able to connect to it using my school computer. Basically, the apps and purchases are still associated with my old account which I can't access, so the new account won't let me activate the device.