Showing results for 
Search instead for 
Did you mean: 

can't use Oculus Go after Meta Account change



Meta forced me to update my Oculus account to a Meta account. After I did this, my Oculus didn't start beyond the repeating three dots... I tried everything, but nothing worked.

Finally I decided to factory reset the headset, removed the device in the Oculus mobile app and remove the app from my phone. 

After I reinstalled the app, I started the Oculus Go. This time it's asking me open the Oculus mobile App to connect the headset. In the App I can 'see' the headset and select is. The App then tries to connect, but tells me this headset is already connected to my Meta-account. It advices me to restore the factory default on the headset, which I have done already several times... is this where I toss a perfectly good headset in the bin, or is there a way that I can still get this to work again?


That was my exact issue. Only thing that worked was downgrading the oculus app to an older version as I posted above 

Hopefully they'll fix the app but I wouldn't hold by breath. 

@sin_of_nature wrote:

That was my exact issue. Only thing that worked was downgrading the oculus app to an older version as I posted above 

Hopefully they'll fix the app but I wouldn't hold by breath. 

My solution is to simply bin my now 5 year old Oculus Go, lol!  Honestly, I think I got pretty good value from it for about 3 years, but after that newer headsets like my Quest 2 and esp, now my Quest Pro, have truly made my poor old Go redundant.  Certainly not worth worrying about anymore, at least not for me anyway.

For those that still want to use it and maybe cannot afford to replace it with more modern gear, I hope that Meta eventually finds a solution for you.  Cheers.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

I have given up hope...

Awesome 👍🏼 it worked with the older 213 version ... you saved my day

I tried older versions till August 2022 but they don't work without login. When I tried to login, I got version "not supported" error. It seems Meta has done a good job in bricking the Oculus Go to boost sales for new model. What is so difficult here that they can't fix despite being aware of it for several months? They could have at least stopped forcing more users to upgrade if this was actually a mistake.

Yeah, You was right. But seeing how they run their business with sending an update to assassinate their old products (Oculus Go and Oculus Quest 1), it hold me back to upgrade to Quest Pro.
Maybe it's better if I still enjoying my Quest 2 and my Rift S for my VR games development, until they send another assassin update to kill both devices. And then I think to buy newer HMD but from other trusted brand.
Oculus <> Meta
I won't put my money in risk for this Meta product in the future. LOL! =))

Honored Guest

Same thing.

the support reps on chat sigh and blow you off. They don’t care. So I will never buy a thing from meta ever again.

Try version 213 ... it's just few weeks old ... it doesn't force you to update and fixed the bluetooth problem 

Community Manager
Community Manager

Hey everyone! We want to let you know the team is aware of the issue that is affecting our Oculus Go community. We also would like to remind everyone that months ago, we announced that we will no longer be selling Oculus Go devices and that we'd continue to maintain the system with bug fixes and security patches through 2022. In addition, we are into the year of 2023 which means we cannot guarantee any future bug or software fixes for the Oculus Go. 


With that being said if we get any updates regarding this issue we'll be sure to let everyone know as soon as possible! We hope this post finds you well and you can refer to this article here regarding what we mentioned. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I ran all the updates on my quest, and the app wouldn't see the device (though it still looks for it). I factory reset the device (per support instructions), so it comes up at the pair screen with the number, but the app doesn't find the device. I created a new account, and tried to pair it with the device... it won't find it either. Just a crap show at this point. Now nothing works, and support's view (based on all the people having the same issue)... You should have done it last year. Really? You should have created an update process that works. The devices were purchased with the understanding that would work even after support ended (perpetual), but that didn't happen so that is on you guys, not us.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?