Showing results for 
Search instead for 
Did you mean: 

can't use Oculus Go after Meta Account change



Meta forced me to update my Oculus account to a Meta account. After I did this, my Oculus didn't start beyond the repeating three dots... I tried everything, but nothing worked.

Finally I decided to factory reset the headset, removed the device in the Oculus mobile app and remove the app from my phone. 

After I reinstalled the app, I started the Oculus Go. This time it's asking me open the Oculus mobile App to connect the headset. In the App I can 'see' the headset and select is. The App then tries to connect, but tells me this headset is already connected to my Meta-account. It advices me to restore the factory default on the headset, which I have done already several times... is this where I toss a perfectly good headset in the bin, or is there a way that I can still get this to work again?


Accepted Solutions

Community Manager
Community Manager

Hey everyone! We want to let you know the team is aware of the issue that is affecting our Oculus Go community. We also would like to remind everyone that months ago, we announced that we will no longer be selling Oculus Go devices and that we'd continue to maintain the system with bug fixes and security patches through 2022. In addition, we are into the year of 2023 which means we cannot guarantee any future bug or software fixes for the Oculus Go. 


With that being said if we get any updates regarding this issue we'll be sure to let everyone know as soon as possible! We hope this post finds you well and you can refer to this article here regarding what we mentioned. 

View solution in original post


Honored Guest

I was having the same exact problem except with a Quest 1 I haven’t factory reset it yet so it’s good to know not to do that.

Community Manager
Community Manager

Hey there, having pairing issues with your headset and mobile app can be the worst, sorry to hear it's giving you such a hard time. We do have a couple of troubleshooting steps for you to try, please let us know if these work.

  1. Factory reset the headset
  2. Uninstall and reinstall the Meta Quest app on your iOS or Android device. 
  3. Open up the Meta Quest app on your iOS or Android device. Wait about a minute while a background update is automatically applied.
  4. Close the Meta Quest app.
  5. Factory reset your headset.
  6. Try to pair your and headset and mobile app as new

These have helped people in the past with the same issue. Let us know if you still need more assistance! 


I've reset the device several times now, I've reinstalled the app on my smartphone, I even tried it on another smartphone. When I try to connect, the app sees the headset, but tells me it is already connectec to my Meta Account.

Hey there YokoshimaOh. We understand you are still having issues with logging into your account. Not to worry, check out this setting up a Meta account article. If that does not work, message us on PM. Please select our name to get to our profile page, or click here: Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. We will be happy to further assist you with this issue!

Honored Guest

They are not supporting the oculus go, it's clear. After all we've done, & I bought 2 oculus go, which are basically doorstops,, they just want us to spend 5x the amount on the meta, & throw our oculus in the trash.

Hey @violet.ebbin! We would like to thank you for being an early adopter of this new reality, and for taking this journey with us. Our focus has shifted to ensure that we can keep pushing what is possible in VR. The Oculus Go was an important stepping stone in the lifecycle of VR, it brought to life a new world for millions of people!

While support for the Oculus Go is limited, we hope you can still find plenty of experiences, wonder and fun with the apps that continue to thrive on the Oculus Go. We hope to continue to see you enjoying the world of VR!

Thank you for your answer but it doesn't solve my same issue. I still have this problem.

Hi, when I “upgraded” my Go to a Meta account it “bricked” it as well. The fax for this is to turn on your Go (you’ll see the endless “…” on the screen), then remove your Go and set it down beside you but do NOT shut it off. 
then open the new Meta App on your mobile device and log into your meta account. Hopefully it’s connected to your Go. (Select Go as your platform in the app if it’s not already.)

you then select an app in the “my library” section of your app on your mobile device. 
you the. Select “launch in the Go” and your app on your mobile device will launch the app on your “bricked” Go. 
put on your Go and the app should be running and you should have full control of your Go again. Everything should be fine. 
it worked with mine and my brother’s Gos. 

I have another issue. When I try to remove Oculus go from my devices after factory reset I have - "An operation was requested for an unknown or inaccessible device exists and try again later"