cancel
Showing results for 
Search instead for 
Did you mean: 

connecting to my pc shows a black screen with 3 loading dots.

lavenderiscooll
Level 2

when I connect to my brothers pc with about the same specs as mine, (aside from his being windows 11), it works fine. enough ram, a good graphics card, and a few more modifications later and I get exited to connect it. much to my dismay, when I enable the link on the headset, it simply shows a black loading screen indefinitely. I've tried a USB 3 and USB 2 cable but both see the same results. I have the oculus app, steam, and steam VR but I cant even get into the menu. the port on my pc is USB 3, (which I've heard is the recommended), so I'm not sure what to do. if anyone has had this issue in the past and fixed it or knows of a possible fix please post it below.

1 REPLY 1

MetaQuestSupport
Community Manager
Community Manager

Hey lavenderiscooll!

Looks like you're having trouble with the Link Cable, that's definitely a pesky thing to have trouble with - let's fix this together! First, please be sure to check if your PC meets all the requirements, be sure your drivers are updated and check for any Windows updates you may need.

If everything is updated and requirements are met, please try the troubleshooting steps below.

Ensure your Link connection is properly established

  1. Open the Oculus PC app on your computer.
  2. Turn on your Quest 2 or Quest.
  3. Plug your USB 3 cable into a USB 3.0 port on your PC, and then plug the other end into your headset.
  4. A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
  5. When prompted to Enable Oculus Link, select Enable to begin remote rendering using Oculus Link.

Repair the Oculus PC Application

  1. Go to https://www.meta.com/quest/setup/ and click Download software.
  2. Select Repair.
    • If Windows asks you if you’re sure you want to open this file, click Yes.
    • If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.
    • If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
    • Please remember to re-enable your antivirus software once you've completed the repair.
  3. Allow the repair process to run, download and install.
  4. Launch the Oculus PC app.

If this doesn't assist with the issue, we suggest following these steps to gather your Oculus Logs and submit a ticket to our Support Team and they'll be able to view and assist further. We hope to have this resolved for you soon!