cancel
Showing results for 
Search instead for 
Did you mean: 

developer mode not turning on

ryneffects
Level 2

i turned on developer mode a while ago and i just went onto side quest for 60hz and it said i need to turn on dev mode so i went there and tried to turn it on and it said something like failed to connect try again later and i did but it didnt turn on but i still have developer settings on my quest any fix

1 REPLY 1

MetaQuestSupport
Community Manager
Community Manager

Hey there @ryneffects! We see you're having a bit of trouble getting Developer Mode activated. We understand how important it is that this feature works properly. We have a few things that you can try to get going again.
 

First, would be to check for any updates on the headset:
 

• Press the universal button (Meta Quest logo) on your right Touch controller to pull up your universal menu.
• Hover over the clock on the left side of the universal menu. When "Quick Settings" appears, select it to open the Quick Settings panel.
• Select "Settings" in the top right corner.
• Select "System" then select "Software Update" from the left menu.
 

Next, if you have not done so already, is to allow content from unknown sources.

 

• Open the Oculus app on your PC computer.
• Select Settings in the left menu.
• Select the General tab.
• Next to Unknown Sources, adjust the toggle and then confirm to allow content from unknown sources.
 

If none of the above options work, you can check out our Developer Resources page. It's full of useful information and helpful tips from the community.