cancel
Showing results for 
Search instead for 
Did you mean: 

quest link problems on oculus 2

corygoldblatt
Honored Guest

I've had a Quest 2 for about 6 months now and I've really never had any major issues with it.  My previous laptop was a Lenovo 5pro with a AMD 4800h and a RTX2060q.  I decided to upgrade to an AW M18 with a i13980 and 4090 specifically for VR as the last laptop struggled with some games (played them smoothly, just felt it needed something a bit heavier duty).

 

I am using the same Oculus and the same USB cable that has always worked.  I only mention that as I don't think the USB cable is the issue here.

Before when I plugged in the USB cable, I would get a message that stated "Allow access to data "Deny" and Allow".  If you clicked Allow, you could transfer files but could not connect with quest link.

I seem to be in a situation where if I connect, I get a message at the bottom, by the notifications, that says  "USB detected"  "Click on this notification to allow access to files".  If you click on that you can access the files.  Was this an update to the newest firmware?  Or did I do something so that I can no longer access the "Deny" or "Allow" prompt that I had in November when I last used this?

I can no longer setup the quest link with my laptop and I have tried all the recommendations I could find online including:

1.  Resetting the oculus to factory settings

2.  Tried multiple USB ports and Cables

3.  Changed the power settings on the USB devices from device manager

4.  Reset my laptop and oculus countless times.

5.  Updated all software and firmware 

 

Also I should note that the oculus app on windows 11 is a bit buggy and cannot close on its own.  I have to use control, alt and delete then manually close it.  It also will not open after that so I have to reset the computer.

 

Any help would be appreciated as I upgraded this to play a few Steam VR games.  Thanks for taking the time to read this.

-Cory

7 REPLIES 7

SavageGamer2993
Honored Guest

I only had an issue with that one time and it was because I did not update my graphics driver and software to my graphics card. But you said you updated all drivers and software, maybe go I to

your quest app on you phone or pc and click on your quest 2 and go to settings and developer mode and switch it on ( you may need to make a developer account) then reset and then try it, hope this helps.

MetaQuestSupport
Community Manager
Community Manager

hello @corygoldblatt! We would love to help you figure out why you are unable to connect via the quest link cable. We know having a headset not connect can affect your ability to join the amazing world of PCVR, and we understand what a unique experience PCVR can be. We appreciate the troubleshooting steps you have taken so far, and in order to get to the bottom of this, we would like to go ahead and start out with some additional troubleshooting steps.

 

Can you please try the following troubleshooting steps?

 

Ensure that USB power settings in Windows Device Manager are not enabled.

  • Open Device Manager
  • Locate the USB ports under Universal Serial Bus controllers
  • Right click and select Properties
  • Navigate to the Power Management tab
  • Ensure that the Allow the computer to turn off this device to save power check box is not checked
     

Disable the USB Selective Suspend Setting

  • Right click the Windows start menu, and select Power Options
  • Click Additional Power Settings
  • Click Change plan settings
  • Click Change Advanced Power Settings
  • Locate the USB Settings and make sure that Selective Suspend Setting is set to Disabled

 

You can also check for other issues like:

  • Any damage to the cable.
  • Try other ports.
  • Try other cables.
  • Repair the PC app.

 

Let us know how this goes!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

corygoldblatt
Honored Guest

This is what has been suggested to me so far and none have seemed to fix the problem.  I have sent the Oculus Log to multiple parties.

"These are the troubleshooting steps that can resolve your concern, kindly follow these steps: 

  • Please remove and remain only one if you are using more than one sound devices. 
  • If you are using Oculus Tray Tool or other third party software that can make modifications to graphics or settings, please uninstall for troubleshooting purposes as these programs can cause conflicts that effect performance and display. 
  • Temporarily disable your Antivirus 
  • Try a different USB 3. port. As a suggestion, you may check your physical ports on your computer if there is any USB ports that is in blue to identify a USB 3.0 port. 
  • Can you try a different play area? 
  • Please disconnect any extra devices connected to the PC leaving only the product hardware, mouse, keyboard and one primary monitor 
  • The next thing that I would like to ask is to check if Game Mode is enabled on your system. Follow the steps below: 
    • Open the Windows Settings menu 
    • Click on Gaming 
    • Click Game Mode 
    • Toggle Game Mode off if it’s turned on 
  1. Ensure their Link connection is properly established:
    1. Open the Meta Quest PC app on your computer.
    2. Turn on your Quest headset.
    3. Plug your USB 3 cable into a USB 3 port on your PC, and then plug the other end into your headset.
    4. A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
    5. When prompted to Enable Meta Quest Link, select Enable to begin remote rendering using Meta Quest Link.
      ReferenceSet up Meta Quest Link
  2. Ensure Air Link is disabled in Settings on the headset.
  1. Go to https://www.meta.com/quest/setup and click Download software.
  2. Select Repair.
    1. If Windows asks you if you’re sure you want to open this file, click Yes.
    2. If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.
    3. If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
    4. Please remember to re-enable your antivirus software once you've completed the repair.
  3. Allow the repair process to run, download and install.
  4. Launch the Meta Quest PC app

nstall the latest Meta Quest drivers.

    1. Close the Meta Quest PC app.
    2. Press the Windows key + R on your keyboard to open the Run command.
    3. Enter C:\Program Files\Oculus\Support\oculus-drivers. (File path may be different per user based on the install location)
    4. Open oculus-driver.
    5. Open the Meta Quest PC app and then try to connect your headset again.

SB power settings

  1. Open Device Manager.
  2. Expand the universal serial bus controllers section at the bottom of the list.
  3. For each item listed under universal serial bus controllers:
    1. Right click and select Properties.
    2. Navigate to Power Management.
    3. Ensure that the options to save power are deselected.
    4. Not all of these listings will have these Power Management options, so we can skip ones that don't, and move onto the next item in the list until completed.
  4. Cold start the Quest headset
    1. With your headset on, hold the power button on the right side of your headset down until you're prompted with a shut-down screen.
    2. Select Shut Down and wait a few minutes before you reboot your Quest headset.

You had mentioned that a repair was done to the PC app. Was this a full manual uninstall through safe mode? If it wasn't, I would recommend that you do try this and see what happens. "

I have tried all of these except reinstalling it in safe mode, which I will try now.  So far nothing seems to have worked.  I should note that the software is buggy on this laptop and frequently crashes.  If it doesn't connect, i cannot close the app and have to click Control, Alt and delete.  One of the representatives mentioned trying an older version of the oculus but she never followed up with the file or the link.  I'll post an update as to whether uninstalling it through safe mode actually helps.

Thanks for your time

 

"version of the oculus but she never followed up with the file or the link.  I'll post an update as to whether uninstalling it through safe mode actually helps." Sorry I meant an older version of the Oculus software for Windows.  Thanks

corygoldblatt
Honored Guest

After uninstalling in safe mode and reinstalling the software, the problems still persist

Hello @corygoldblatt! Thank you so much for providing us with all the troubleshooting steps you have gone through. At this point we would like to take a closer look into this for you. In order for us to protect your personal information, we would like to request that you go ahead and reach out to us privately. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed in to the community first to send us a private message.

 

We look forward to hearing back from you, and thank you for your patience.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there! We are just following up with you in order to check and see if you still need help with connecting to your Quest 2 via Quest Link. If you still do need assistance with this, feel free to reach out to us anytime. We are here to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!