cancel
Showing results for 
Search instead for 
Did you mean: 

quest2 cannot connect to my computer

xiaobai114514
Explorer

In January 2023 I started using quest2 to connect to my computer. When connected, three dots will appear on the quest2 screen as it loads. After loading for a while, the screen goes black. I was trying to find a way to connect to the internet and I turned off the integrated graphics and then back on. I tried to connect to the computer using quest2, and it connected after a while. After updating the graphics card driver two days ago, I tried to connect to quest2 using the original method in a new place. I turned the integrated graphics off and on again. This time, after a while it still couldn't connect. I've tried various methods. Still unable to connect, I came to the forum to ask for help.

7 REPLIES 7

J40NYR
MVP
MVP

hi @xiaobai114514 

What specs are your machine?

You definitely want to disable your internal graphics to be sure you're on the right track.

What cable are you using?

It may be worth trying to connect using airlink, could narrow the issue down somewhat

Jonny

Quest 2 and 3 PCVR

MetaQuestSupport
Community Manager
Community Manager

Hey there! We appreciate you reaching out to us regarding this issue. We definitely know how important getting your PC connected to your device is to gaming, and want you to get the best experience while exploring the Metaverse. So rest assured, we'll be happy to assist you. 

To start, we'd like to gather a few details from you to look into this a bit further:

  • Have you tried using Airlink?
  • Have you attempted to disable your graphics card?
  • Could you clarify for us what cable you are using?

We'll be looking forward to hearing back from you on this.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hey there! We're just following up with you to see if you still need assistance. If so, please feel free to reach back out, we're always happy to help. We hope you have a great day!


 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you very much for replying to me. My quest2 problem has been temporarily solved. Before that, I turned off the core display. I can connect to quest2 but the frame rate is very low. After I downloaded the original graphics card driver from the Acer official website, I can use Airlink to connect to quest2. The wired connection cable is USB3

Laptop, the connected cable is USB3, and airlink cannot be connected either.

No worries @xiaobai114514, We're happy to help out! Sounds like you're making some progress, so that's great to hear. For your wired Link connection, are you using the cable that came with your Quest 2? It'd also help us and the other community members out with getting you properly set up, if you could share your system specifications with us. For reference, you should also check out our Link Compatibility page.

 

We would like the following:

  • Processor (CPU)
  • Graphics Card (GPU)
  • Windows Build & Version
  • Memory (RAM)

If you're getting frame-rate issues when running PCVR, be sure to tweak your in-game graphic settings, since PCVR tends to be pretty demanding. If you're getting stuttering/choppy-ness with your Air Link connection, we recommend checking out our Air Link best practices to make sure your setup is as optimal as it can be for the best performance! If your setup is different to our best practices, please let us know so we can delve more into it.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

My processor is AMD Ryzen 7 5800H with Radeon Graphics
My graphics card is NVIDIA GeForce RTX 3050 Ti Laptop GPU
My system is Windows 10 Microsoft Windows version 22H2 (OS Build 19045.3693)
Memory is 16.0 GB